summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-08-07 06:03:16 +0200
committerHans de Graaff <graaff@gentoo.org>2018-08-07 06:03:16 +0200
commitd5fb38a28602165dcf8a02ebb5c749747e91cfc5 (patch)
tree18bc458971737cc1f1ca13c0f1cbfb61ef01bf7f /dev-ruby/rspec-expectations
parentnet-wireless/aircrack-ng: support 8812au (diff)
downloadgentoo-d5fb38a28602165dcf8a02ebb5c749747e91cfc5.tar.gz
gentoo-d5fb38a28602165dcf8a02ebb5c749747e91cfc5.tar.bz2
gentoo-d5fb38a28602165dcf8a02ebb5c749747e91cfc5.zip
dev-ruby/rspec-expectations: add 3.8.1
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-ruby/rspec-expectations')
-rw-r--r--dev-ruby/rspec-expectations/Manifest1
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-3.8.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-ruby/rspec-expectations/Manifest b/dev-ruby/rspec-expectations/Manifest
index 5ba53219e84f..fc881df73931 100644
--- a/dev-ruby/rspec-expectations/Manifest
+++ b/dev-ruby/rspec-expectations/Manifest
@@ -3,3 +3,4 @@ DIST rspec-expectations-3.5.0-git.tgz 187600 BLAKE2B 607dabc38e077ed82e18cdc6909
DIST rspec-expectations-3.6.0-git.tgz 193897 BLAKE2B f3fc2b06a317e77838e2d483416ab0e05aefed8a129058ceaf1a80d3068b41e81abc9fd85576433fd1577e6114ccc65130734b850997f89310b80b549f80d679 SHA512 5c784eff2c076623f471bcfff6e014420782c8d52ff54a68adc9b4d6b60a91726da36e3989535f4ab7f1fcc6b1e2a3c3a63ee330f8ea55f475711741762c0f07
DIST rspec-expectations-3.7.0-git.tgz 194071 BLAKE2B 67c8db15c43cc1141b19c6eb99390eaaf2535ec03f0fdc7b05576daa463d252f56ff251d40f5771726ee6451d57eef206c893f2593b01d413b5d96cdf21f0daf SHA512 bdd3222089299e9bfdd6f17a2b8af81d5e695290a3ce976630d586d51ff2df5baf76a3887b8adb31294bd6623ba85f8c2a4a31ac520046515aeeb81fa3a1bd5a
DIST rspec-expectations-3.8.0-git.tgz 198184 BLAKE2B 4bd191885a7944ca4909a1275618726cd0fff95352ef7e88f05d94e5f7088632d2c9ac7a9f47ea94c79e3665198482098daf7f6fc286c59563c8efbdee585241 SHA512 7157dcf09c18d2b56156ba4c1b0bc1a11cb98ab05e43ab9cbd65eea3f796cadf3319711d4e9837905cbba8d70cf297aea47f1f8631fd7a97be763dd33ce08002
+DIST rspec-expectations-3.8.1-git.tgz 198732 BLAKE2B 243dccbf1771bda4a445abdadfbb79e67ad2e3a2a92013bcefdf746bcb6a3c99c1c999c15cf3a0ed324d587463ce57676785670ee5b2fa85ee216359b694bb64 SHA512 91d637210ccc4322073ce3e258b923de0e69f0a6eb0f07dd31bfe41da0a0ff18685c289e02c3ccabdea0f332ad55dbcb197fc16c7d6b144958e11cc90bfc8496
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-3.8.1.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-3.8.1.ebuild
new file mode 100644
index 000000000000..f478350c65ef
--- /dev/null
+++ b/dev-ruby/rspec-expectations/rspec-expectations-3.8.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem eapi7-ver
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec-expectations"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+SUBVERSION="$(ver_cut 1-2)"
+
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.2.0 <dev-ruby/diff-lcs-2
+ =dev-ruby/rspec-support-${SUBVERSION}*"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-mocks-3.2.0:3
+ >=dev-ruby/rspec-support-3.5.0:3
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm -f Gemfile || die
+
+ # fix up the gemspecs
+ sed -i \
+ -e '/git ls/d' \
+ -e '/add_development_dependency/d' \
+ "${RUBY_FAKEGEM_GEMSPEC}" || die
+}