summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-10-25 07:30:01 +0200
committerHans de Graaff <graaff@gentoo.org>2019-10-25 07:31:34 +0200
commitbd4812f3066d1d34d648988cd3c73d395eab7369 (patch)
tree8bf431e37287ec0e7423d3f75d9f74c4184b6ad8 /dev-ruby/rspec/rspec-3.9.0.ebuild
parentdev-ruby/rspec-core: add 3.9.0 (diff)
downloadgentoo-bd4812f3066d1d34d648988cd3c73d395eab7369.tar.gz
gentoo-bd4812f3066d1d34d648988cd3c73d395eab7369.tar.bz2
gentoo-bd4812f3066d1d34d648988cd3c73d395eab7369.zip
dev-ruby/rspec: add 3.9.0
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rspec/rspec-3.9.0.ebuild')
-rw-r--r--dev-ruby/rspec/rspec-3.9.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/rspec/rspec-3.9.0.ebuild b/dev-ruby/rspec/rspec-3.9.0.ebuild
new file mode 100644
index 000000000000..bd1aef3eb6d2
--- /dev/null
+++ b/dev-ruby/rspec/rspec-3.9.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+SUBVERSION="$(ver_cut 1-2)"
+
+ruby_add_rdepend "
+ =dev-ruby/rspec-core-${SUBVERSION}*
+ =dev-ruby/rspec-expectations-${SUBVERSION}*
+ =dev-ruby/rspec-mocks-${SUBVERSION}*"