summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/ruby-feedparser
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/ruby-feedparser')
-rw-r--r--dev-ruby/ruby-feedparser/Manifest1
-rw-r--r--dev-ruby/ruby-feedparser/metadata.xml8
-rw-r--r--dev-ruby/ruby-feedparser/ruby-feedparser-0.9.3.ebuild45
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-ruby/ruby-feedparser/Manifest b/dev-ruby/ruby-feedparser/Manifest
new file mode 100644
index 000000000000..b74c7a182cef
--- /dev/null
+++ b/dev-ruby/ruby-feedparser/Manifest
@@ -0,0 +1 @@
+DIST ruby_feedparser_0.9.3.tar.gz 2504432 SHA256 362b2d43f79e36bf2f42fbe8a9c3b48599fd11cd1730f2f3eea5716502fed6ac SHA512 832952503d330387f74e9b12c23144e40963b909df7f11cc4968466b0222bb5313c53f254a870ebc3e9f66d1d999c60e468ac58aa397e580a229fe43304dd865 WHIRLPOOL 9ff1f1fcc63310e608d046cfff56d62aae79ebc1ec0dc3e22695a400323337bcd9ae64e72b43916f579c7e82fd37e1e0962a34aaf7f02fa8614defb72aebcbda
diff --git a/dev-ruby/ruby-feedparser/metadata.xml b/dev-ruby/ruby-feedparser/metadata.xml
new file mode 100644
index 000000000000..7081df69bfcb
--- /dev/null
+++ b/dev-ruby/ruby-feedparser/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">feed2imap/ruby-feedparser</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/ruby-feedparser/ruby-feedparser-0.9.3.ebuild b/dev-ruby/ruby-feedparser/ruby-feedparser-0.9.3.ebuild
new file mode 100644
index 000000000000..417d8d5faa1c
--- /dev/null
+++ b/dev-ruby/ruby-feedparser/ruby-feedparser-0.9.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README"
+
+inherit ruby-fakegem
+
+GITHUB_USER="feed2imap"
+
+DESCRIPTION="Ruby library to parse ATOM/RSS feeds"
+HOMEPAGE="https://github.com/feed2imap/ruby-feedparser"
+SRC_URI="https://github.com/${GITHUB_USER}/${PN}/archive/${P//-/_}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+RUBY_S="${PN}-${P//-/_}"
+
+ruby_add_rdepend "dev-ruby/magic"
+
+ruby_add_bdepend "dev-ruby/magic
+ test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -i -e 's/::Config/::RbConfig/' setup.rb || die
+}
+
+each_ruby_prepare() {
+ sed -i -e '/PKG_VERSION/ s:ruby:'${RUBY}':' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} setup.rb config || die
+}
+
+each_ruby_install() {
+ ${RUBY} setup.rb install --prefix="${D}" || die
+}