summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/ruby-termios
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/ruby-termios')
-rw-r--r--dev-ruby/ruby-termios/Manifest1
-rw-r--r--dev-ruby/ruby-termios/metadata.xml8
-rw-r--r--dev-ruby/ruby-termios/ruby-termios-1.0.0-r1.ebuild46
-rw-r--r--dev-ruby/ruby-termios/ruby-termios-1.0.0.ebuild46
4 files changed, 101 insertions, 0 deletions
diff --git a/dev-ruby/ruby-termios/Manifest b/dev-ruby/ruby-termios/Manifest
new file mode 100644
index 000000000000..d8c92682fa58
--- /dev/null
+++ b/dev-ruby/ruby-termios/Manifest
@@ -0,0 +1 @@
+DIST ruby-termios-1.0.0.tar.gz 14738 SHA256 0b6c41fb554acf17d257db8e8a10b283be6a9b45807ef1562151aadfc008ce5f SHA512 16d71a8cf84391da2dc8b138ff381751f5a72d61ce37d2215960d389285dee14862b50cf770d4648b298df093a85005df460ba951c5d7e6fb38e69d8d686599a WHIRLPOOL 34c9ad7fdfb7f72d8311a04345f5aa94050ea5d0fd66d362cd7c9eca55b19b91dd022bf2b3e60714a78c4e80bfc28952d722e8538372a3ed7faed8443baa85e3
diff --git a/dev-ruby/ruby-termios/metadata.xml b/dev-ruby/ruby-termios/metadata.xml
new file mode 100644
index 000000000000..b0019a7158d0
--- /dev/null
+++ b/dev-ruby/ruby-termios/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">arika/ruby-termios</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/ruby-termios/ruby-termios-1.0.0-r1.ebuild b/dev-ruby/ruby-termios/ruby-termios-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..732c0670fbd6
--- /dev/null
+++ b/dev-ruby/ruby-termios/ruby-termios-1.0.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+inherit multilib ruby-ng
+
+DESCRIPTION="A Ruby interface to termios"
+HOMEPAGE="http://arika.org/ruby/termios"
+SRC_URI="https://github.com/arika/ruby-termios/archive/version_${PV//./_}.tar.gz -> ${P}.tar.gz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~x86 ~x86-macos"
+IUSE=""
+
+RUBY_S="${PN}-version_${PV//./_}"
+
+# Tests require a normal TTY, bug 340575. They should all pass when run
+# manually.
+RESTRICT=test
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext V=1
+ cp ext/termios$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test0.rb || die "tests failed"
+}
+
+each_ruby_install() {
+ emake V=1 -Cext DESTDIR="${D}" install
+}
+
+all_ruby_install() {
+ dodoc ChangeLog README termios.rd
+
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+}
diff --git a/dev-ruby/ruby-termios/ruby-termios-1.0.0.ebuild b/dev-ruby/ruby-termios/ruby-termios-1.0.0.ebuild
new file mode 100644
index 000000000000..8f3adcae0c12
--- /dev/null
+++ b/dev-ruby/ruby-termios/ruby-termios-1.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+inherit multilib ruby-ng
+
+DESCRIPTION="A Ruby interface to termios"
+HOMEPAGE="http://arika.org/ruby/termios"
+SRC_URI="https://github.com/arika/ruby-termios/archive/version_${PV//./_}.tar.gz -> ${P}.tar.gz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~mips ~ppc x86 ~x86-macos"
+IUSE=""
+
+RUBY_S="${PN}-version_${PV//./_}"
+
+# Tests require a normal TTY, bug 340575. They should all pass when run
+# manually.
+RESTRICT=test
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext V=1
+ cp ext/termios$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test0.rb || die "tests failed"
+}
+
+each_ruby_install() {
+ emake V=1 -Cext DESTDIR="${D}" install
+}
+
+all_ruby_install() {
+ dodoc ChangeLog README termios.rd
+
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+}