summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-03-27 08:13:54 +0200
committerHans de Graaff <graaff@gentoo.org>2022-03-27 09:13:12 +0200
commit90c1b947474174ca04ccae5374374b0a12ab0c33 (patch)
tree67837080d73fea42add74b1687af59d441ab511c /dev-ruby/time/time-0.2.0.ebuild
parentdev-ruby/date: initial import of 3.2.2 (diff)
downloadgentoo-90c1b947474174ca04ccae5374374b0a12ab0c33.tar.gz
gentoo-90c1b947474174ca04ccae5374374b0a12ab0c33.tar.bz2
gentoo-90c1b947474174ca04ccae5374374b0a12ab0c33.zip
dev-ruby/time: initial import of 0.2.0
Extracted from dev-lang/ruby, keywords set accordingly. Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/time/time-0.2.0.ebuild')
-rw-r--r--dev-ruby/time/time-0.2.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/time/time-0.2.0.ebuild b/dev-ruby/time/time-0.2.0.ebuild
new file mode 100644
index 000000000000..ae7b805d59f6
--- /dev/null
+++ b/dev-ruby/time/time-0.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="time.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Extends the Time class with methods for parsing and conversion"
+HOMEPAGE="https://github.com/ruby/time"
+SRC_URI="https://github.com/ruby/time/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test:test/lib -rhelper -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}