summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-09-17 07:37:50 +0200
committerHans de Graaff <graaff@gentoo.org>2019-09-17 07:38:04 +0200
commit15e5b7da57e9c627100e9319b98c099eb209bcdb (patch)
tree7d30a2c50458297bb2511d60265a66dbc68e2f83 /dev-ruby/x25519/x25519-1.0.8.ebuild
parentdev-util/debhelper: Old (diff)
downloadgentoo-15e5b7da57e9c627100e9319b98c099eb209bcdb.tar.gz
gentoo-15e5b7da57e9c627100e9319b98c099eb209bcdb.tar.bz2
gentoo-15e5b7da57e9c627100e9319b98c099eb209bcdb.zip
dev-ruby/x25519: initial import of 1.0.8
New dependency for forthcoming dev-ruby/net-ssh release. Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/x25519/x25519-1.0.8.ebuild')
-rw-r--r--dev-ruby/x25519/x25519-1.0.8.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/x25519/x25519-1.0.8.ebuild b/dev-ruby/x25519/x25519-1.0.8.ebuild
new file mode 100644
index 000000000000..bdc8cd16bb92
--- /dev/null
+++ b/dev-ruby/x25519/x25519-1.0.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="x25519.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Key exchange via the X25519 (Curve25519) Elliptic Curve Diffie-Hellman function"
+HOMEPAGE="https://github.com/crypto-rb/x25519"
+SRC_URI="https://github.com/crypto-rb/x25519/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#: ; /coverall/I s:^:#:' spec/spec_helper.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/x25519_precomputed extconf.rb || die
+ ${RUBY} -Cext/x25519_ref10 extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/x25519_precomputed
+ cp ext/x25519_precomputed/x25519_precomputed.so lib/ || die
+ emake V=1 -Cext/x25519_ref10
+ cp ext/x25519_ref10/x25519_ref10.so lib/ || die
+}