summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-02-07 07:37:38 +0100
committerHans de Graaff <graaff@gentoo.org>2018-02-07 08:04:49 +0100
commit3a3d7c973596089851c86f00de634193743438c2 (patch)
tree56828541b3fa8982b39581ccf157a963eff3dfbb /dev-ruby
parentdev-db/phpmyadmin: x86 stable (bug #645700) (diff)
downloadgentoo-3a3d7c973596089851c86f00de634193743438c2.tar.gz
gentoo-3a3d7c973596089851c86f00de634193743438c2.tar.bz2
gentoo-3a3d7c973596089851c86f00de634193743438c2.zip
dev-ruby/omniauth: cleanup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/omniauth/Manifest2
-rw-r--r--dev-ruby/omniauth/omniauth-1.6.1.ebuild46
-rw-r--r--dev-ruby/omniauth/omniauth-1.7.1.ebuild46
3 files changed, 0 insertions, 94 deletions
diff --git a/dev-ruby/omniauth/Manifest b/dev-ruby/omniauth/Manifest
index f748ec48f82f..f6f2ed063c67 100644
--- a/dev-ruby/omniauth/Manifest
+++ b/dev-ruby/omniauth/Manifest
@@ -1,3 +1 @@
-DIST omniauth-1.6.1.tar.gz 25094 BLAKE2B 45fa6c9d5eb249d5650adaf5e7a89e35ade8613cbc051b76e57b3332f26b8bc18a1645120a0590828c5dedc3034cf8ce5f107d1bcf88054cf5d27abb8d44c723 SHA512 5cb372ef4c8b78d5d110eb3f2f828ac3af5d14f230ed3a7d81f0464e21f0d3a434604fe2102874a3b6c341cbe9ad4db4af575229c77592c11e756bb38ab3b80b
-DIST omniauth-1.7.1.tar.gz 26002 BLAKE2B 180d0eba2a4dc6289411e5a56ee776dc1bb0a799d4f3c735803986b6d47e4de4d50e670157a2996b10e4d80d57f322a296d24af18b87b6c6de669dbd64253fd1 SHA512 ed951394f996eb7eb9ab90fb6e46957f8f85148cc29ffb90697a0f74819014327a8e1fb6e8dbd5be736961c7283dc6132586841d05b87043b8d5a20c12441f68
DIST omniauth-1.8.1.tar.gz 26016 BLAKE2B ad7f22a847bd91385ddce44efc89fb312b07ffe43d2b0fab3773e7c809959eb8a8b4567af5ba1a1e9fb9d559b692dec358bf16d6b1cb21b85f13521c20fa3415 SHA512 ad085d067971f3fef40e99be7f2e58a9bb006b404f8d7289c5c00be4ed7314ff9d40409053d2bda0a5072035d6e09295d22b8ae6b5d2a84384b245b5a0ae225a
diff --git a/dev-ruby/omniauth/omniauth-1.6.1.ebuild b/dev-ruby/omniauth/omniauth-1.6.1.ebuild
deleted file mode 100644
index ddea4b3b8f5d..000000000000
--- a/dev-ruby/omniauth/omniauth-1.6.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby21 ruby22 ruby23"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_RECIPE_DOC="none"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A generalized Rack framework for multiple-provider authentication"
-HOMEPAGE="https://github.com/intridea/omniauth"
-SRC_URI="https://github.com/intridea/omniauth/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="MIT"
-KEYWORDS="~amd64"
-SLOT="0"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/rack-1.6.2:* <dev-ruby/rack-3:*
- >=dev-ruby/hashie-3.4.6:3 <dev-ruby/hashie-3.6.0:3"
-ruby_add_bdepend "doc? ( dev-ruby/yard )
- test? ( dev-ruby/rack-test )"
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/d' \
- Rakefile ${PN}.gemspec || die "sed failed"
- sed -i -e '/RUBY_VERSION/,/^end/ s:^:#:' spec/helper.rb || die "sed failed"
- # maruku fails, resorting to default markdown implementation
- sed -i -e '/maruku/d' .yardopts || die "sed failed"
-
- sed -i -e '/s.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use doc ; then
- yard || die "yard failed"
- fi
-}
diff --git a/dev-ruby/omniauth/omniauth-1.7.1.ebuild b/dev-ruby/omniauth/omniauth-1.7.1.ebuild
deleted file mode 100644
index 2c597ca30306..000000000000
--- a/dev-ruby/omniauth/omniauth-1.7.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_RECIPE_DOC="none"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A generalized Rack framework for multiple-provider authentication"
-HOMEPAGE="https://github.com/intridea/omniauth"
-SRC_URI="https://github.com/intridea/omniauth/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="MIT"
-KEYWORDS="~amd64"
-SLOT="0"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/rack-1.6.2:* <dev-ruby/rack-3:*
- >=dev-ruby/hashie-3.4.6:3 <dev-ruby/hashie-3.6.0:3"
-ruby_add_bdepend "doc? ( dev-ruby/yard )
- test? ( dev-ruby/rack-test )"
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/d' \
- Rakefile ${PN}.gemspec || die "sed failed"
- sed -i -e '/RUBY_VERSION/,/^end/ s:^:#:' spec/helper.rb || die "sed failed"
- # maruku fails, resorting to default markdown implementation
- sed -i -e '/maruku/d' .yardopts || die "sed failed"
-
- sed -i -e '/s.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use doc ; then
- yard || die "yard failed"
- fi
-}