summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-02-08 06:10:49 +0100
committerHans de Graaff <graaff@gentoo.org>2018-02-08 07:24:18 +0100
commit4824d939e121a42bb11a9edccdacd906de055980 (patch)
tree05b443ad6dd0a29a3ad38d395a31daa1896dd3d8 /dev-ruby
parentdev-ruby/paint: cleanup (diff)
downloadgentoo-4824d939e121a42bb11a9edccdacd906de055980.tar.gz
gentoo-4824d939e121a42bb11a9edccdacd906de055980.tar.bz2
gentoo-4824d939e121a42bb11a9edccdacd906de055980.zip
dev-ruby/parallel: cleanup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/parallel/Manifest1
-rw-r--r--dev-ruby/parallel/parallel-1.12.0.ebuild54
2 files changed, 0 insertions, 55 deletions
diff --git a/dev-ruby/parallel/Manifest b/dev-ruby/parallel/Manifest
index 39aac437743f..f42e992931e9 100644
--- a/dev-ruby/parallel/Manifest
+++ b/dev-ruby/parallel/Manifest
@@ -1,2 +1 @@
-DIST parallel-1.12.0.tar.gz 20472 BLAKE2B b6e998588f94e07194c19d4bf38964aa5e846b7f62c7a267041473a237a9d8fdebb4dc501695b00902c852021ce7817b24bfe01dcf4c0e18445b46d46c7cb42b SHA512 8ca41cf577ee4743ef50abe693d0040eaab12b61eca17c3d6c33d3720c38563e2df9a0eb5af0fe9d8c34c3b910f1c626ce141fd2eb7d2edfbe5abbcb9f54191b
DIST parallel-1.12.1.tar.gz 20499 BLAKE2B f0fa25b9fe65e44804854f703dd2d80e53572e64c2072c418d0462922bd04f89cff0e023caf4293d8a1504ad66a2a29ebbdd01920fc6fe400837859da0f0eb78 SHA512 f0ab332dfa60bb3190bba8275dbdf7b54d3de205ab76099d11f0a64e1fc28e1ba7e72d1a242bd615015c2d09a3f08df01c382869fd6990b854b01fe182245857
diff --git a/dev-ruby/parallel/parallel-1.12.0.ebuild b/dev-ruby/parallel/parallel-1.12.0.ebuild
deleted file mode 100644
index ae6e3c6512aa..000000000000
--- a/dev-ruby/parallel/parallel-1.12.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby21 ruby22 ruby23"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="Readme.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Run any code in parallel Processes or Threads"
-HOMEPAGE="https://github.com/grosser/parallel"
-LICENSE="MIT"
-SRC_URI="https://github.com/grosser/parallel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~amd64"
-SLOT="1"
-IUSE="test"
-
-DEPEND+="test? ( sys-process/lsof )"
-
-ruby_add_bdepend "
- test? ( dev-ruby/ruby-progressbar dev-ruby/activerecord:4.2 dev-ruby/sqlite3 )"
-
-each_ruby_prepare() {
- # Make sure the correct ruby is used for testing
- sed -e 's:ruby :'${RUBY}' :' -i spec/parallel_spec.rb || die
-}
-
-all_ruby_prepare() {
- sed -i -e '/bundler/ s:^:#:' \
- -e '1i require "tempfile"; gem "activerecord", "~>4.2.0"' spec/cases/helper.rb || die
- sed -i -e '3irequire "timeout"' spec/spec_helper.rb || die
-
- # Avoid a failing spec regarding to pipes. The spec seems like it
- # should always fail.
- sed -e '/does not open unnecessary pipes/,/end/ s:^:#:' \
- -i spec/parallel_spec.rb || die
-
- # Avoid fragile ar sqlite tests. They throw ReadOnly errors every now and then.
- sed -i -e '/works with SQLite in/,/end/ s:^:#:' spec/parallel_spec.rb || die
-
- # Avoid spec broken on Ruby 2.1 that clearly doesn't match code and doesn't really test anything
- sed -i -e '/doesnt use Etc.nprocessors in Ruby 2.1 and below/,/end/ s:^:#:' spec/parallel_spec.rb || die
-}
-
-each_ruby_test() {
- # Set RUBYLIB explicitly for the ruby's that get started from the specs.
- TRAVIS=true RUBYLIB="lib" ${RUBY} -S rspec-3 spec || die
-}