summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-09-10 07:44:11 +0200
committerHans de Graaff <graaff@gentoo.org>2017-09-10 07:51:45 +0200
commit4c14277648c5715770881aabf5b701ab41a9998c (patch)
tree78baa3fcaf12b08186218e35d65a3714a805d840 /dev-ruby
parentprofiles: mask net-libs/qmf and dev-qt/qt-mobility for removal (diff)
downloadgentoo-4c14277648c5715770881aabf5b701ab41a9998c.tar.gz
gentoo-4c14277648c5715770881aabf5b701ab41a9998c.tar.bz2
gentoo-4c14277648c5715770881aabf5b701ab41a9998c.zip
dev-ruby/activesupport: add rails 5.1.4
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activesupport/Manifest1
-rw-r--r--dev-ruby/activesupport/activesupport-5.1.4.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index 6768311e8666..ecf68adc92a5 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -7,3 +7,4 @@ DIST rails-5.0.6.tgz 6043860 SHA256 be73ef6f421f0657a16fd2e9c3a582930d26cf30ab64
DIST rails-5.1.1.tgz 6124695 SHA256 a09bfa7d2917865778af70dff8bd57fe01820eca0228cff85de581ee17e9adf2 SHA512 fd62506eac440f1ad9b37f20c7c712733440bc2ee676390c02e3bd50b912fe0fd53e8092c23664d47818ee62583568c6e20d2bfd5eff6d22a005289bb3bb258f WHIRLPOOL a23d6644126e6e01481c48c7089208a535188b5b32ad67cb69db36ac2044ee35bd95d4012076d7f12666aed2cbe984c75c3555889923710f10b1b91c150ccc73
DIST rails-5.1.2.tgz 6124489 SHA256 cd6173b2ca492397d1cf22190a3070f1af485c2e25f7d9b3c2d0a80f553b4aae SHA512 95072d06ce19726343758f4dbdac96728598e31be0a0560f240511bf043aab47d55530ef47bd9b390aa61b5e0ad6e142781ed7167ce7f2cf11d22a71127d7872 WHIRLPOOL ba3d0e231f4307343c6c955ecc273ac2e507d503f58a859ea81addd945bd8007190d45f18afbf3ec6915872af324a27dd2377927efe5e6c857e2ca09b6549fce
DIST rails-5.1.3.tgz 6130089 SHA256 1d8f5f504173207eb8a418e071c75f656684ac4fea4b0e07d737c1c9accad423 SHA512 5aa9f7e5211e8dd36b7bb54ab7dc0e88241253ab560355497da2eff9c5bae5dab877640ce8e066fd637e145752af7e1942743359ab8028e6376bc905a9b18236 WHIRLPOOL 0561f9f386b8ab0c732302e369d159b65766a744b1784cbdabfbab46e27219128dd8bc39e262ae3d137ea3a03402174bfe7318fe87b00b2f28cf084f9089afff
+DIST rails-5.1.4.tgz 6132874 SHA256 d04168edcc8a230b80e77b766c86264a72456b56650fc45e41e5b9eb6ead1a26 SHA512 8f0837e0a2c5b0189375f10310a6e6b43e32f1fecc503582efc6490436c943e774495262e508e4ca1a1874132ae6e4a541e81c06f0d8f6fe8ab85bd2fd10d4fc WHIRLPOOL b2e51c627627b1d88e8415349aacfae14b9270727090e4460ac4ddd8f34ced3b56b3345cb00158be14b7283bd56673a4c770f053ce02d98db1d10f5351a0778b
diff --git a/dev-ruby/activesupport/activesupport-5.1.4.ebuild b/dev-ruby/activesupport/activesupport-5.1.4.ebuild
new file mode 100644
index 000000000000..73176ccfc8de
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-5.1.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/concurrent-ruby-1.0.2:1
+ >=dev-ruby/i18n-0.7:* =dev-ruby/i18n-0*:*
+ >=dev-ruby/tzinfo-1.1:1
+ >=dev-ruby/minitest-5.1:5"
+
+# memcache-client, nokogiri, and builder are not strictly
+# needed, but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-2.2.1
+ >=dev-ruby/nokogiri-1.4.5
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/listen-3.0.5:3
+ dev-ruby/rack
+ dev-ruby/mocha:0.14
+ <dev-ruby/minitest-5.4
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\|rack-cache\|sqlite\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' \
+ -e 's/gemspec/gemspec path: "activesupport"/' \
+ -e '5igem "builder"; gem "rack"' ../Gemfile || die
+ rm ../Gemfile.lock || die
+
+ # Avoid test that depends on timezone
+ sed -i -e '/test_implicit_coercion/,/^ end/ s:^:#:' test/core_ext/duration_test.rb || die
+
+ # Avoid tests that seem to trigger race conditions.
+ rm -f test/evented_file_update_checker_test.rb || die
+}