summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-11-17 08:01:33 +0100
committerHans de Graaff <graaff@gentoo.org>2016-11-17 08:01:58 +0100
commitbbb4cf4fedaf0d8a98be12c30df4f13a1ab32dc7 (patch)
treee93f0e4c9fdc00f5edac24a285f87b2eb31cb989 /dev-ruby
parentdev-ruby/gh: fix FEATURES=test (diff)
downloadgentoo-bbb4cf4fedaf0d8a98be12c30df4f13a1ab32dc7.tar.gz
gentoo-bbb4cf4fedaf0d8a98be12c30df4f13a1ab32dc7.tar.bz2
gentoo-bbb4cf4fedaf0d8a98be12c30df4f13a1ab32dc7.zip
dev-ruby/net-http-pipeline: fix tests; add ruby22, ruby23
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/net-http-pipeline/files/net-http-pipeline-accept-encoding.patch18
-rw-r--r--dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild4
2 files changed, 21 insertions, 1 deletions
diff --git a/dev-ruby/net-http-pipeline/files/net-http-pipeline-accept-encoding.patch b/dev-ruby/net-http-pipeline/files/net-http-pipeline-accept-encoding.patch
new file mode 100644
index 000000000000..3adfdf28afdc
--- /dev/null
+++ b/dev-ruby/net-http-pipeline/files/net-http-pipeline-accept-encoding.patch
@@ -0,0 +1,18 @@
+--- test/test_net_http_pipeline.rb.old 2016-11-17 07:58:57.284997283 +0100
++++ test/test_net_http_pipeline.rb 2016-11-17 07:58:50.345168508 +0100
+@@ -96,6 +96,7 @@
+ def http_get
+ get = []
+ get << 'GET / HTTP/1.1'
++ get << 'Accept-Encoding: gzip;q=1.0,deflate;q=0.6,identity;q=0.3'
+ get << 'Accept: */*'
+ get << 'User-Agent: Ruby' if RUBY_VERSION > '1.9'
+ get.push nil, nil
+@@ -106,6 +107,7 @@
+ def http_post
+ get = []
+ get << 'POST / HTTP/1.1'
++ get << 'Accept-Encoding: gzip;q=1.0,deflate;q=0.6,identity;q=0.3'
+ get << 'Accept: */*'
+ get << 'User-Agent: Ruby' if RUBY_VERSION > '1.9'
+ get.push nil, nil
diff --git a/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild b/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild
index f9cfa202eab6..fe348b5ee472 100644
--- a/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild
+++ b/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild
@@ -3,7 +3,7 @@
# $Id$
EAPI=5
-USE_RUBY="ruby20 ruby21"
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
inherit ruby-fakegem
@@ -16,6 +16,8 @@ SLOT="1"
KEYWORDS="~amd64"
IUSE=""
+RUBY_PATCHES=( ${PN}-accept-encoding.patch )
+
ruby_add_bdepend "
dev-ruby/hoe
test? ( dev-ruby/minitest )