summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-01-01 09:13:33 +0100
committerHans de Graaff <graaff@gentoo.org>2024-01-01 10:32:09 +0100
commite293030b9dfb35dc1bf27a286b5a7ac05463bde9 (patch)
treed81ba0f3ae33383b4e3974889a211c2f31538476 /dev-ruby
parentdev-ruby/rbnacl: enable ruby33 (diff)
downloadgentoo-e293030b9dfb35dc1bf27a286b5a7ac05463bde9.tar.gz
gentoo-e293030b9dfb35dc1bf27a286b5a7ac05463bde9.tar.bz2
gentoo-e293030b9dfb35dc1bf27a286b5a7ac05463bde9.zip
dev-ruby/puppet-resource_api: add 1.9.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/puppet-resource_api/Manifest1
-rw-r--r--dev-ruby/puppet-resource_api/puppet-resource_api-1.9.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/puppet-resource_api/Manifest b/dev-ruby/puppet-resource_api/Manifest
index b8152ae5c105..264c8fd200e7 100644
--- a/dev-ruby/puppet-resource_api/Manifest
+++ b/dev-ruby/puppet-resource_api/Manifest
@@ -1 +1,2 @@
DIST puppet-resource_api-1.8.16.tar.gz 167691 BLAKE2B 58aad4a73ef76fbccab580c1500b4af6a472f9bc9b7b0b1c592626abb837af6b34697194b5da884f87ce306f00f23d6f17ff7926e88ca2df3b0cd5770c819e9c SHA512 b60575d0e4f87425d028429403dd5524e39cb5ffea338871f7c5296d7e632d4eebc6786bdb7005e5c1be5e962115903b11dc9645dacd4d040d3afa43606a3ea2
+DIST puppet-resource_api-1.9.0.tar.gz 168292 BLAKE2B 469c59c07e22d7bb9cd9c00bb95b3efe5af8a1a985155ec5a0286f912a5afa95504d7fa9f24c6b00307d88e06dce035021f4c8570c9a7a81de7f5e195d1a4719 SHA512 009900910fc83bbc5d96d51d5d069a527c271786143c080774d90d6ba89f5451a2a949965f852a83a7d4ac964a9db0756c7f698d4f3f6c7631e4164ff545f9c6
diff --git a/dev-ruby/puppet-resource_api/puppet-resource_api-1.9.0.ebuild b/dev-ruby/puppet-resource_api/puppet-resource_api-1.9.0.ebuild
new file mode 100644
index 000000000000..194148a7cf54
--- /dev/null
+++ b/dev-ruby/puppet-resource_api/puppet-resource_api-1.9.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md CONTRIBUTING.md HISTORY.md README.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+# rspec tests have dependencies not packaged in Gentoo at this time:
+# puppetlabs_spec_helper
+# CFPropertyList
+# simplecov-console
+# spec-puppet
+# rubocop
+# rubocop-rspec
+# license_finder
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This library provides a simple way to write new native resources for puppet."
+HOMEPAGE="https://rubygems.org/gems/puppet-resource_api https://github.com/puppetlabs/puppet-resource_api"
+LICENSE="MIT"
+# 2023/03/19: .gem does not contain specfiles, and lags behind GitHub releases.
+SRC_URI="https://github.com/puppetlabs/puppet-resource_api/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # the gemspec tries to system(git ls-files) but has a meaningful fallback, so just make it not run git.
+ sed -e 's:__FILE__:"puppet-resource_api.gemspec":' \
+ -e 's/__dir__/"."/' \
+ -i "${RUBY_FAKEGEM_GEMSPEC}" \
+ || die
+}
+
+ruby_add_rdepend ">=dev-ruby/hocon-1.0"