summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-06-02 08:00:30 +0200
committerHans de Graaff <graaff@gentoo.org>2018-06-02 08:01:20 +0200
commite861d158ff44b0eeb185cdad89ad6251162285b6 (patch)
tree4a81a5e15549e0dd25438e4c80c03d23c7e560a7 /dev-ruby
parentdev-ruby/haml: cleanup (diff)
downloadgentoo-e861d158ff44b0eeb185cdad89ad6251162285b6.tar.gz
gentoo-e861d158ff44b0eeb185cdad89ad6251162285b6.tar.bz2
gentoo-e861d158ff44b0eeb185cdad89ad6251162285b6.zip
dev-ruby/haml: allow parallel installation of slots
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/haml/haml-4.0.7-r2.ebuild49
-rw-r--r--dev-ruby/haml/haml-5.0.4.ebuild2
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-ruby/haml/haml-4.0.7-r2.ebuild b/dev-ruby/haml/haml-4.0.7-r2.ebuild
new file mode 100644
index 000000000000..f2c698f635d3
--- /dev/null
+++ b/dev-ruby/haml/haml-4.0.7-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+RUBY_FAKEGEM_TASK_DOC="-Ilib doc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md REFERENCE.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby web page templating engine"
+HOMEPAGE="http://haml-lang.com/"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="doc test"
+
+RDEPEND="${RDEPEND} !!<dev-ruby/haml-3.1.8-r2"
+
+ruby_add_rdepend "dev-ruby/tilt:*"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/minitest:5
+ dev-ruby/nokogiri
+ dev-ruby/rails:4.2
+ dev-ruby/bundler
+ )
+ doc? (
+ dev-ruby/yard
+ >=dev-ruby/maruku-0.7.2-r1
+ )"
+
+all_ruby_prepare() {
+ # Remove test that fails when RedCloth is available
+ sed -i -e "/should raise error when a Tilt filters dependencies are unavailable for extension/,+9 s/^/#/"\
+ test/filters_test.rb || die
+ # Avoid tests that are fragile for whitespace
+ sed -i -e '/test_\(text_area\|partials_should_not_cause_textareas\)/,/^ end/ s:^:#:' test/helper_test.rb || die
+}
diff --git a/dev-ruby/haml/haml-5.0.4.ebuild b/dev-ruby/haml/haml-5.0.4.ebuild
index 5edf17354124..22d89343e9a2 100644
--- a/dev-ruby/haml/haml-5.0.4.ebuild
+++ b/dev-ruby/haml/haml-5.0.4.ebuild
@@ -25,7 +25,7 @@ KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~amd64-linux ~x86-linux ~ppc-macos ~x64-
IUSE="doc test"
-RDEPEND="${RDEPEND} !!<dev-ruby/haml-3.1.8-r2"
+RDEPEND="${RDEPEND} !!<dev-ruby/haml-4.0.7-r2"
ruby_add_rdepend ">=dev-ruby/temple-0.8.0 dev-ruby/tilt:*"