summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-scheme/schemik
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-scheme/schemik')
-rw-r--r--dev-scheme/schemik/Manifest1
-rw-r--r--dev-scheme/schemik/files/schemik-1.2.40.0-asneeded.patch15
-rw-r--r--dev-scheme/schemik/metadata.xml15
-rw-r--r--dev-scheme/schemik/schemik-1.2.40.0.ebuild40
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-scheme/schemik/Manifest b/dev-scheme/schemik/Manifest
new file mode 100644
index 000000000000..fc00b3fcf14e
--- /dev/null
+++ b/dev-scheme/schemik/Manifest
@@ -0,0 +1 @@
+DIST schemik-1.2.40.0.tar.gz 132603 SHA256 cadee740b9b651dd52c384ef8356cefa9b326d15bf69a3f0344e9303c6975ab1
diff --git a/dev-scheme/schemik/files/schemik-1.2.40.0-asneeded.patch b/dev-scheme/schemik/files/schemik-1.2.40.0-asneeded.patch
new file mode 100644
index 000000000000..07083e6e96e8
--- /dev/null
+++ b/dev-scheme/schemik/files/schemik-1.2.40.0-asneeded.patch
@@ -0,0 +1,15 @@
+Fixing build with as-needed, respect LDFLAGS
+
+http://bugs.gentoo.org/show_bug.cgi?id=330623
+
+--- Makefile
++++ Makefile
+@@ -4,7 +4,7 @@
+ STATIC_NAME="schemik-i686-linux-static"
+
+ all: stack_eval.o types.o functions.o env.o initial_env.o schemik.c rt.o int_funcs.o readline_wrapper.o config.h thread_pool.o parser.o lexer.o errors.o
+- $(CC) ${COMP_ARGS} `pkg-config --libs --cflags glib-2.0` -o schemik stack_eval.o types.o int_funcs.o functions.o env.o initial_env.o rt.o readline_wrapper.o thread_pool.o parser.o lexer.o errors.o schemik.c -lgc -lpthread -lreadline -lncurses -lm
++ $(CC) $(LDFLAGS) ${COMP_ARGS} -o schemik stack_eval.o types.o int_funcs.o functions.o env.o initial_env.o rt.o readline_wrapper.o thread_pool.o parser.o lexer.o errors.o schemik.c -lgc -lpthread -lreadline -lncurses -lm `pkg-config --libs --cflags glib-2.0`
+
+ stack_eval.o: stack_eval.c eval.h vm.h vm.c stack.c stack.h int_funcs.h functions.h rt.h mutex.h types.h config.h dump_vm.c tm_log.c tm_log.h constants.def
+ $(CC) ${COMP_ARGS} `pkg-config --cflags glib-2.0` -c stack_eval.c
diff --git a/dev-scheme/schemik/metadata.xml b/dev-scheme/schemik/metadata.xml
new file mode 100644
index 000000000000..a87597a84f29
--- /dev/null
+++ b/dev-scheme/schemik/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>scheme</herd>
+ <longdescription lang="en">
+ Schemik is a high-level lexically-scoped implicitly-parallel dialect of
+ Scheme and Common LISP, this means the parallel execution of programs is
+ done independently of the programmer and each program written in Schemik
+ always produces the same results no matter which parts of the program are
+ executed simultaneously.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">schemik</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-scheme/schemik/schemik-1.2.40.0.ebuild b/dev-scheme/schemik/schemik-1.2.40.0.ebuild
new file mode 100644
index 000000000000..693896be8315
--- /dev/null
+++ b/dev-scheme/schemik/schemik-1.2.40.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit toolchain-funcs versionator eutils
+
+DESCRIPTION="High-level lexically-scoped implicitly-parallel dialect of Scheme and Common LISP"
+HOMEPAGE="http://schemik.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/boehm-gc
+ >=dev-libs/glib-2.0
+ sys-libs/readline"
+
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ sed -i -e 's/\(COMP_ARGS=\)-g \(-Wall -Winline\) -O2/\1$(CFLAGS) \2/' \
+ Makefile || die "patching Makefile failed"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)|| die "emake failed"
+}
+
+src_install() {
+ dobin schemik || die "dobin failed"
+ insinto "/usr/share/${PN}/$(get_version_component_range 1-2)"
+ doins "scm/base.scm" || die "Standard library installation failed"
+ dodoc ChangeLog README || die "dodoc failed"
+ doman doc/man/schemik.1.gz || die "doman failed"
+}