summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-12-02 22:17:25 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-12-02 22:17:25 +0900
commitbde7aec9acbad4782f5f69b79a831ddfc717ef94 (patch)
treeca97057169f93b305e3ac3a46211b2d7d02895de /dev-scheme
parentdev-scheme/tinyscheme: update patch (diff)
downloadgentoo-bde7aec9acbad4782f5f69b79a831ddfc717ef94.tar.gz
gentoo-bde7aec9acbad4782f5f69b79a831ddfc717ef94.tar.bz2
gentoo-bde7aec9acbad4782f5f69b79a831ddfc717ef94.zip
dev-scheme/tinyscheme: update to EAPI 8
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/tinyscheme/metadata.xml9
-rw-r--r--dev-scheme/tinyscheme/tinyscheme-1.41-r1.ebuild50
-rw-r--r--dev-scheme/tinyscheme/tinyscheme-1.41.ebuild62
3 files changed, 58 insertions, 63 deletions
diff --git a/dev-scheme/tinyscheme/metadata.xml b/dev-scheme/tinyscheme/metadata.xml
index ac49f95d58ff..71fee92b23b1 100644
--- a/dev-scheme/tinyscheme/metadata.xml
+++ b/dev-scheme/tinyscheme/metadata.xml
@@ -6,7 +6,14 @@
<name>Gentoo Scheme Project</name>
</maintainer>
<longdescription lang="en">
-TinyScheme is a lightweight Scheme interpreter that implements as large a subset of R5RS as was possible without getting very large and complicated. It is meant to be used as an embedded scripting interpreter for other programs. As such, it does not offer IDEs or extensive toolkits although it does sport a small top-level loop, included conditionally. A lot of functionality in TinyScheme is included conditionally, to allow developers freedom in balancing features and footprint.
+ TinyScheme is a lightweight Scheme interpreter that implements as large
+ a subset of R5RS as was possible without getting very large and
+ complicated. It is meant to be used as an embedded scripting
+ interpreter for other programs. As such, it does not offer IDEs or
+ extensive toolkits although it does sport a small top-level loop,
+ included conditionally. A lot of functionality in TinyScheme is
+ included conditionally, to allow developers freedom in balancing
+ features and footprint.
</longdescription>
<upstream>
<remote-id type="sourceforge">tinyscheme</remote-id>
diff --git a/dev-scheme/tinyscheme/tinyscheme-1.41-r1.ebuild b/dev-scheme/tinyscheme/tinyscheme-1.41-r1.ebuild
new file mode 100644
index 000000000000..65386c50ba9e
--- /dev/null
+++ b/dev-scheme/tinyscheme/tinyscheme-1.41-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Lightweight scheme interpreter"
+HOMEPAGE="https://tinyscheme.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="static-libs"
+
+RDEPEND=""
+DEPEND=""
+
+PATCHES=( "${FILESDIR}"/${PN}-makefile.patch )
+DOCS=( CHANGES {Manual,MiniSCHEMETribute,hack}.txt )
+
+src_compile() {
+ emake \
+ AR=$(tc-getAR) \
+ CC=$(tc-getCC) \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ local tslib=lib${PN}$(get_libname)
+ local tslibx=lib${PN}$(get_libname ${PV})
+
+ newbin scheme ${PN}
+
+ newlib.so ${tslib} ${tslibx}
+ dosym ${tslibx} /usr/$(get_libdir)/${tslib}
+ use static-libs && dolib.a lib${PN}.a
+ einstalldocs
+
+ # bug #328967
+ insinto /usr/include
+ newins scheme.h ${PN}.h
+
+ local INIT_DIR=/usr/share/${PN}
+ insinto ${INIT_DIR}
+ doins init.scm
+ dodir /etc/env.d
+ echo "TINYSCHEMEINIT=\"${EPREFIX}${INIT_DIR}/init.scm\"" >"${ED}"/etc/env.d/50${PN}
+}
diff --git a/dev-scheme/tinyscheme/tinyscheme-1.41.ebuild b/dev-scheme/tinyscheme/tinyscheme-1.41.ebuild
deleted file mode 100644
index e1f5b2da4cdc..000000000000
--- a/dev-scheme/tinyscheme/tinyscheme-1.41.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit epatch flag-o-matic multilib toolchain-funcs
-
-DESCRIPTION="Lightweight scheme interpreter"
-HOMEPAGE="https://tinyscheme.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-#KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos ~x64-macos"
-KEYWORDS="amd64 ppc x86"
-IUSE="static-libs"
-
-DEPEND=""
-RDEPEND=""
-
-src_prepare() {
-
- epatch "${FILESDIR}"/${PN}-makefile.patch
-
- if [[ ${CHOST} == *-darwin* ]] ; then
- append-flags -DOSX
- sed -i \
- -e 's/SOsuf=so/SOsuf=dylib/' \
- -e "s|-Wl,-soname=|-Wl,-install_name=${EPREFIX}/usr/lib/|" \
- makefile || die
- fi
-}
-
-src_compile() {
- emake LDFLAGS="${LDFLAGS}"\
- AR=$(tc-getAR) CC=$(tc-getCC)
-}
-
-src_install() {
-
- local tslib=libtinyscheme$(get_libname)
- local tslibx=libtinyscheme$(get_libname ${PV})
-
- newbin scheme ${PN}
-
- newlib.so ${tslib} ${tslibx}
- dosym ${tslibx} /usr/$(get_libdir)/${tslib}
- dodoc Manual.txt
-
- if use static-libs; then
- dolib.a libtinyscheme.a
- fi
-
- # Bug 328967: dev-scheme/tinyscheme-1.39-r1 doesn't install header file
- insinto /usr/include/
- newins scheme.h tinyscheme.h
-
- local INIT_DIR=/usr/share/${PN}/
- insinto ${INIT_DIR}
- doins init.scm
- dodir /etc/env.d/ && echo "TINYSCHEMEINIT=\"${EPREFIX}${INIT_DIR}init.scm\"" > "${ED}"/etc/env.d/50tinyscheme
-}