summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2024-10-29 18:22:56 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2024-10-29 18:22:56 +0100
commit16baae0250870f34c3ad3c35ecbab86f530009a9 (patch)
tree56b2fbd58896edcafe8fedfcf7fbccd23f70849a /dev-tcltk/tdom/tdom-0.9.2-r1.ebuild
parentdev-ruby/ruby-augeas: drop 0.5.0-r5, 0.5.0-r6 (diff)
downloadgentoo-16baae0250870f34c3ad3c35ecbab86f530009a9.tar.gz
gentoo-16baae0250870f34c3ad3c35ecbab86f530009a9.tar.bz2
gentoo-16baae0250870f34c3ad3c35ecbab86f530009a9.zip
dev-tcltk/tdom: drop 0.9.2-r1
Bug: https://bugs.gentoo.org/884415 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-tcltk/tdom/tdom-0.9.2-r1.ebuild')
-rw-r--r--dev-tcltk/tdom/tdom-0.9.2-r1.ebuild83
1 files changed, 0 insertions, 83 deletions
diff --git a/dev-tcltk/tdom/tdom-0.9.2-r1.ebuild b/dev-tcltk/tdom/tdom-0.9.2-r1.ebuild
deleted file mode 100644
index fab0aebae09e..000000000000
--- a/dev-tcltk/tdom/tdom-0.9.2-r1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools flag-o-matic
-
-MY_P="tDOM-${PV}"
-
-DESCRIPTION="A XML/DOM/XPath/XSLT Implementation for Tcl"
-HOMEPAGE="https://core.tcl.tk/tdom/"
-SRC_URI="http://tdom.org/downloads/${P}-src.tgz"
-
-LICENSE="MPL-1.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="threads"
-
-DEPEND="
- dev-lang/tcl:0=
- dev-libs/expat"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}"/${P}-src
-
-PATCHES=(
- "${FILESDIR}"/${P}-useCC.patch
- "${FILESDIR}"/${P}-nothreads.patch
- "${FILESDIR}"/${P}-clang6.patch
-)
-
-src_prepare() {
- append-libs -lm
- sed \
- -e 's:-O2::g' \
- -e 's:-pipe::g' \
- -e 's:-fomit-frame-pointer::g' \
- -e '/SHLIB_LD_LIBS/s:\"$: ${TCL_LIB_FLAG}":g' \
- -i tclconfig/tcl.m4 || die
- mv extensions/tnc/configure.{in,ac} || die
- mv extensions/example/configure.{in,ac} || die
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_enable threads)
- --enable-shared
- --with-tcl="${EPREFIX}"/usr/$(get_libdir)
- )
-
- cd "${S}"/unix && ECONF_SOURCE=".." econf ${myeconfargs} \
- --disable-tdomalloc --with-expat
- cd "${S}"/extensions/tdomhtml && econf
- cd "${S}"/extensions/tnc && econf ${myeconfargs}
-}
-
-src_compile() {
- local dir
-
- for dir in "${S}"/unix "${S}"/extensions/tnc; do
- pushd ${dir} > /dev/null
- emake
- popd > /dev/null
- done
-}
-
-src_test() {
- cd unix && default
-}
-
-src_install() {
- local dir
-
- dodoc CHANGES ChangeLog README*
-
- for dir in "${S}"/unix "${S}"/extensions/tdomhtml "${S}"/extensions/tnc; do
- pushd ${dir} > /dev/null
- emake DESTDIR="${D}" install
- popd > /dev/null
- done
-}