summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tcltk/tktable
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tcltk/tktable')
-rw-r--r--dev-tcltk/tktable/Manifest1
-rw-r--r--dev-tcltk/tktable/metadata.xml8
-rw-r--r--dev-tcltk/tktable/tktable-2.10.ebuild32
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-tcltk/tktable/Manifest b/dev-tcltk/tktable/Manifest
new file mode 100644
index 000000000000..446fc5d412fd
--- /dev/null
+++ b/dev-tcltk/tktable/Manifest
@@ -0,0 +1 @@
+DIST Tktable2.10.tar.gz 284135 SHA256 c335117fa1be45fe4d3032e96fd4b4641fff6a4f8467878608dabed11198a4cb SHA512 d69b1c766abb2833f48c900ca4d4fd3927f138ddf728dd76f2087a784604daa4356ec60a146e71d2fb2508a644598711e0373cb81dbfb0272b7ad16a0754e899 WHIRLPOOL 514be8c8048c947ddb9a59c35105f4f81848de51aa70d6961a739b8077683019baa583042dd4a1e807e51abdcd51ab95f9f69e3a0963a7c6c21fc456c023ea6d
diff --git a/dev-tcltk/tktable/metadata.xml b/dev-tcltk/tktable/metadata.xml
new file mode 100644
index 000000000000..2aa34a4a39b9
--- /dev/null
+++ b/dev-tcltk/tktable/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tcltk</herd>
+ <upstream>
+ <remote-id type="sourceforge">tktable</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-tcltk/tktable/tktable-2.10.ebuild b/dev-tcltk/tktable/tktable-2.10.ebuild
new file mode 100644
index 000000000000..98f0cbb16b69
--- /dev/null
+++ b/dev-tcltk/tktable/tktable-2.10.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+MY_P="Tktable${PV}"
+
+DESCRIPTION="full-featured 2D table widget"
+HOMEPAGE="http://tktable.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tktable/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="amd64 ppc x86"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-lang/tk-8.0"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -e '/^install:/{s: install-doc::}' \
+ -e '/^PKG_EXTRA_FILES/{s:=.*:=:}' -i Makefile.in || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dohtml doc/tkTable.html || die
+ dodoc ChangeLog README.txt release.txt || die
+}