summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tcltk/togl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tcltk/togl')
-rw-r--r--dev-tcltk/togl/Manifest1
-rw-r--r--dev-tcltk/togl/metadata.xml28
-rw-r--r--dev-tcltk/togl/togl-2.0-r2.ebuild47
3 files changed, 76 insertions, 0 deletions
diff --git a/dev-tcltk/togl/Manifest b/dev-tcltk/togl/Manifest
new file mode 100644
index 000000000000..5857aad57e7f
--- /dev/null
+++ b/dev-tcltk/togl/Manifest
@@ -0,0 +1 @@
+DIST Togl2.0-src.tar.gz 244968 SHA256 b7d4a90bbad3aca618d505ee99e7fd8fb04c829f63231dda2360f557ba3f7610 SHA512 2be3062baada848d96b2802582bc5590b215f2ab4dc02c91761e72af2bf8c0ba768a71a2ffb8107bca83b63b7d1321ee83de19b97f83b1c2f0962f9288948b0a WHIRLPOOL 6f4a8d69d74c499899002250b35f7dbac093035338716f9ee24b3f1d9b876ff302cb4727dadfda08f2f81dda1074a136bb8a51b335931bc97303c6c56fd155c2
diff --git a/dev-tcltk/togl/metadata.xml b/dev-tcltk/togl/metadata.xml
new file mode 100644
index 000000000000..d41cba32a9ab
--- /dev/null
+++ b/dev-tcltk/togl/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tcltk</herd>
+ <longdescription>
+Togl is a Tk widget for OpenGL rendering. Togl was originally based on
+OGLTK, written by Benjamin Bederson at the University of New Mexico. Togl's
+main features are:
+
+* unifies Microsoft Windows, X11 (Linux/IRIX/...), and Mac OS X Aqua support
+* support for requesting stencil, accumulation, alpha buffers, etc.
+* multiple OpenGL drawing windows
+* simple stereo rendering support
+* simple, portable font support
+* color-index mode support including color allocation functions
+* overlay plane support
+* OpenGL extension testing from Tcl
+* Tcl Extension Architecture (TEA) 3 compliant
+
+Togl does almost no OpenGL drawing itself, instead it manages OpenGL
+drawing by calling various Tcl commands (a.k.a., callback functions). Those
+commands can be C functions that call OpenGL (in)directly or another Tcl
+package (e.g., Tcl3D).
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">togl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-tcltk/togl/togl-2.0-r2.ebuild b/dev-tcltk/togl/togl-2.0-r2.ebuild
new file mode 100644
index 000000000000..217ac21c27a6
--- /dev/null
+++ b/dev-tcltk/togl/togl-2.0-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+MY_P=Togl${PV}
+
+DESCRIPTION="A Tk widget for OpenGL rendering"
+HOMEPAGE="http://togl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug +threads"
+
+RDEPEND="
+ dev-lang/tk
+ virtual/opengl
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}"
+
+# tests directory is missing
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed \
+ -e 's:-fomit-frame-pointer::g' \
+ -e 's:-O2::g' \
+ -e 's:-pipe::g' \
+ -i configure || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug symbols) \
+ $(use_enable threads)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dohtml doc/*
+ dodoc README*
+}