summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-01-18 07:37:24 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-01-18 07:38:05 +0100
commit2861672ff56c6c5938425c10aaa5b89a0b52af09 (patch)
treeb94e02cecb5dc31f9434932bd7103400cc72f5c6 /dev-tcltk
parentdev-util/gitlab-runner: drop 15.4.1, 15.6.1, 15.7.1 (diff)
downloadgentoo-2861672ff56c6c5938425c10aaa5b89a0b52af09.tar.gz
gentoo-2861672ff56c6c5938425c10aaa5b89a0b52af09.tar.bz2
gentoo-2861672ff56c6c5938425c10aaa5b89a0b52af09.zip
dev-tcltk/togl: update EAPI 7 -> 8
Closes: https://bugs.gentoo.org/881207 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/togl/files/togl-2.0-clang6.patch11
-rw-r--r--dev-tcltk/togl/togl-2.0-r4.ebuild48
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-tcltk/togl/files/togl-2.0-clang6.patch b/dev-tcltk/togl/files/togl-2.0-clang6.patch
new file mode 100644
index 000000000000..e227c2236f8f
--- /dev/null
+++ b/dev-tcltk/togl/files/togl-2.0-clang6.patch
@@ -0,0 +1,11 @@
+--- a/togl.c 2023-01-18 07:31:37.816199176 +0100
++++ b/togl.c 2023-01-18 07:33:08.946629940 +0100
+@@ -132,7 +132,7 @@
+ /* pointer to Tk_SetClassProcs function in the stub table */
+
+ static void (*SetClassProcsPtr)
+- _ANSI_ARGS_((Tk_Window, Tk_ClassProcs *, ClientData));
++ _ANSI_ARGS_((Tk_Window, const Tk_ClassProcs *, ClientData));
+ #endif
+
+ /*
diff --git a/dev-tcltk/togl/togl-2.0-r4.ebuild b/dev-tcltk/togl/togl-2.0-r4.ebuild
new file mode 100644
index 000000000000..b6c050d682e5
--- /dev/null
+++ b/dev-tcltk/togl/togl-2.0-r4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P=Togl${PV}
+
+DESCRIPTION="A Tk widget for OpenGL rendering"
+HOMEPAGE="http://togl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +threads"
+
+RDEPEND="
+ dev-lang/tk:*
+ media-libs/mesa[X]
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}"
+
+# tests directory is missing
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${P}-clang6.patch )
+
+src_prepare() {
+ default
+ sed \
+ -e 's:-fomit-frame-pointer::g' \
+ -e 's:-O2::g' \
+ -e 's:-pipe::g' \
+ -i configure || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug symbols) \
+ $(use_enable threads)
+}
+
+src_install() {
+ HTML_DOCS=( doc/* )
+ default
+}