summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/atomic-install
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/atomic-install')
-rw-r--r--dev-util/atomic-install/Manifest1
-rw-r--r--dev-util/atomic-install/atomic-install-0.1.1.ebuild29
-rw-r--r--dev-util/atomic-install/atomic-install-9999.ebuild44
-rw-r--r--dev-util/atomic-install/metadata.xml16
4 files changed, 90 insertions, 0 deletions
diff --git a/dev-util/atomic-install/Manifest b/dev-util/atomic-install/Manifest
new file mode 100644
index 000000000000..e4804f1446e6
--- /dev/null
+++ b/dev-util/atomic-install/Manifest
@@ -0,0 +1 @@
+DIST atomic-install-0.1.1.tar.bz2 279555 SHA256 941ecd58029e691539d799b0e4fa8f90f5018d8d3bf44dfe0c244f219d03c615 SHA512 6614b47ab24f3ce480dd977983c2117836418915a13689e301922dce3091cfbb4dfec412402fa4c68f77d15c7dc297f14d70c12aeccab98d77af0a3534f29c8a WHIRLPOOL d6e8429441810eaae456593beeacdab5db8303b60f8ad7c88e0a51b178a6daac35735fdf96481ddb96628ef8c9904aeac2247928865c3f00df0d7e97b0fd136b
diff --git a/dev-util/atomic-install/atomic-install-0.1.1.ebuild b/dev-util/atomic-install/atomic-install-0.1.1.ebuild
new file mode 100644
index 000000000000..bee6b11f03ea
--- /dev/null
+++ b/dev-util/atomic-install/atomic-install-0.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="A library and tool to atomically install sets of files"
+HOMEPAGE="https://github.com/mgorny/atomic-install/"
+SRC_URI="mirror://github/mgorny/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs xattr"
+
+RDEPEND="xattr? ( sys-apps/attr )"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.18 )"
+
+src_configure() {
+ myeconfargs=(
+ $(use_enable doc gtk-doc)
+ $(use_enable xattr libattr)
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/dev-util/atomic-install/atomic-install-9999.ebuild b/dev-util/atomic-install/atomic-install-9999.ebuild
new file mode 100644
index 000000000000..7e911d1cf119
--- /dev/null
+++ b/dev-util/atomic-install/atomic-install-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="git://github.com/mgorny/${PN}.git
+ http://github.com/mgorny/${PN}.git"
+
+inherit git-2
+#endif
+
+inherit autotools-utils
+
+DESCRIPTION="A library and tool to atomically install sets of files"
+HOMEPAGE="https://github.com/mgorny/atomic-install/"
+SRC_URI="mirror://github/mgorny/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs xattr"
+
+RDEPEND="xattr? ( sys-apps/attr )"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.18 )"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+DEPEND="${DEPEND}
+ >=dev-util/gtk-doc-1.18"
+#endif
+
+src_configure() {
+ myeconfargs=(
+ $(use_enable doc gtk-doc)
+ $(use_enable xattr libattr)
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/dev-util/atomic-install/metadata.xml b/dev-util/atomic-install/metadata.xml
new file mode 100644
index 000000000000..1e50b7ed36cd
--- /dev/null
+++ b/dev-util/atomic-install/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <bugs-to>https://github.com/mgorny/atomic-install/issues/</bugs-to>
+ <remote-id type="github">mgorny/atomic-install</remote-id>
+ </upstream>
+</pkgmetadata>