summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-15 02:19:16 +0000
committerSam James <sam@gentoo.org>2024-03-15 02:19:39 +0000
commit01e19560620d39e0ab0ada96d7b12b21f80b950e (patch)
tree093a83904ad6d59d08a2752585e13e5e35646bb2 /dev-util/autoproject
parentdev-python/pytesseract: Stabilize 0.3.12 x86, #926809 (diff)
downloadgentoo-01e19560620d39e0ab0ada96d7b12b21f80b950e.tar.gz
gentoo-01e19560620d39e0ab0ada96d7b12b21f80b950e.tar.bz2
gentoo-01e19560620d39e0ab0ada96d7b12b21f80b950e.zip
dev-util/autoproject: add 0.20_p15
Closes: https://bugs.gentoo.org/296630 Closes: https://bugs.gentoo.org/631312 Closes: https://bugs.gentoo.org/632255 Closes: https://bugs.gentoo.org/872989 Closes: https://bugs.gentoo.org/898578 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/autoproject')
-rw-r--r--dev-util/autoproject/Manifest1
-rw-r--r--dev-util/autoproject/autoproject-0.20_p15.ebuild54
-rw-r--r--dev-util/autoproject/files/autoproject-0.20_p15-getopt-cxx-conflict-noexcept.patch12
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-util/autoproject/Manifest b/dev-util/autoproject/Manifest
index 4b144d342d63..01add2aae54b 100644
--- a/dev-util/autoproject/Manifest
+++ b/dev-util/autoproject/Manifest
@@ -1,2 +1,3 @@
+DIST autoproject_0.20-15.debian.tar.xz 7716 BLAKE2B a6969da3e5cac3aa02c6d878a13b8643867761c7f1c26a1bb1cc8469ac5e08f717a013418108c5b82aeb186b19677a1c1915e8b5d9785b650f7e44a976949f5f SHA512 ab74a3058b0a03d87baef5cdf0c8bb96dca71dea6ae28416249762542b076be7abdbe99f0ac9a8251bae1f2802f28af8aa6f087de64aef4f2c87a79877caebca
DIST autoproject_0.20-5.diff.gz 5287 BLAKE2B 3bc26c42876606c8a8a879a888ec1c51fac8de2b380ef10c1c346a35dcd4747b21264cf4d2161e55ea31d49393569a897aa98ff1b0a8576465fd5e06b77fd27a SHA512 156f8feff53936c3113bda9d8a3f2e19679f249656ace69aacb1f0a13ae93066eef49de3e5a268c47ed3e440144de629f6b84a477ecfc6a3f793c41412cc9b5a
DIST autoproject_0.20.orig.tar.gz 151101 BLAKE2B 657a4a4baae35b038392c2cc78a1ab0e657229587e64105f0a6150ce83c29cd2305b716b12e706ea31fc31f091f21fc8b00f89dbcd753453944ee26f7fbc01f1 SHA512 eb6ba12af96e03f4da51b6b9fc0db618180d92b8a363f30182013a003bb13f5b66ee12b28531a234f6035b64bda29bb0f838466ccbeaddbce06a437a18c05288
diff --git a/dev-util/autoproject/autoproject-0.20_p15.ebuild b/dev-util/autoproject/autoproject-0.20_p15.ebuild
new file mode 100644
index 000000000000..1b3fed7d0827
--- /dev/null
+++ b/dev-util/autoproject/autoproject-0.20_p15.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV=${PV%_p*}
+DEB_VER=${PV#*_p}
+
+inherit autotools
+
+DESCRIPTION="Start a programming project using autotools and a command line parser generator"
+HOMEPAGE="https://packages.debian.org/unstable/devel/autoproject"
+SRC_URI="
+ mirror://debian/pool/main/a/autoproject/${PN}_${MY_PV}.orig.tar.gz
+ mirror://debian/pool/main/a/autoproject/${PN}_${MY_PV}-${DEB_VER}.debian.tar.xz
+"
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-build/autoconf:*
+ dev-build/automake:*
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ sys-apps/texinfo
+ sys-devel/autogen
+ )
+"
+
+PATCHES=(
+ "${WORKDIR}"/debian/patches
+ "${FILESDIR}"/${PN}-0.20_p15-getopt-cxx-conflict-noexcept.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e 's:configure.in:configure.ac:' Makefile.am || die
+ eautoreconf
+}
+
+src_test() {
+ # chkclig: clig is an optional dep and it isn't packaged in Gentoo
+ # (nor in Debian since 2009)
+ # chkag: fails, unclear why
+ emake check XFAIL_TESTS="chkclig chkag"
+}
diff --git a/dev-util/autoproject/files/autoproject-0.20_p15-getopt-cxx-conflict-noexcept.patch b/dev-util/autoproject/files/autoproject-0.20_p15-getopt-cxx-conflict-noexcept.patch
new file mode 100644
index 000000000000..d881b7275ca3
--- /dev/null
+++ b/dev-util/autoproject/files/autoproject-0.20_p15-getopt-cxx-conflict-noexcept.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/872989
+--- a/lib/cli/c++/none/getopt.h
++++ b/lib/cli/c++/none/getopt.h
+@@ -131,7 +131,7 @@ struct option
+ /* Many other libraries have conflicting prototypes for getopt, with
+ differences in the consts, in stdlib.h. To avoid compilation
+ errors, only prototype getopt for the GNU C library. */
+-extern int getopt (int __argc, char *const *__argv, const char *__shortopts);
++extern int getopt (int __argc, char *const *__argv, const char *__shortopts) noexcept;
+ # else /* not __GNU_LIBRARY__ */
+ extern int getopt ();
+ # endif /* __GNU_LIBRARY__ */