summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2016-04-30 21:57:33 +1000
committerSam Jorna <wraeth@gentoo.org>2016-05-01 00:33:58 +1000
commit50d8d91f5889bdd4b664835067dbc56212b11333 (patch)
treef367fda4aee90cefb70637fb8ad638525d16845f /dev-util/bats
parenteclass/ros-catkin.eclass: use emake tests with nonfatal as nonfatal is still ... (diff)
downloadgentoo-50d8d91f5889bdd4b664835067dbc56212b11333.tar.gz
gentoo-50d8d91f5889bdd4b664835067dbc56212b11333.tar.bz2
gentoo-50d8d91f5889bdd4b664835067dbc56212b11333.zip
dev-util/bats: new package
Bats is a TAP-compliant testing framework for Bash. It provides a simple way to verify that the UNIX programs you write behave as expected. This has been added in order to support app-admin/yadm in bug 581118. Maintainer assigned to Espen H per request under Proxy Maintainers. Gentoo-bug: 581392 Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-util/bats')
-rw-r--r--dev-util/bats/Manifest1
-rw-r--r--dev-util/bats/bats-0.4.0.ebuild24
-rw-r--r--dev-util/bats/metadata.xml26
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-util/bats/Manifest b/dev-util/bats/Manifest
new file mode 100644
index 000000000000..f74b43f3eab0
--- /dev/null
+++ b/dev-util/bats/Manifest
@@ -0,0 +1 @@
+DIST bats-0.4.0.tar.gz 17258 SHA256 480d8d64f1681eee78d1002527f3f06e1ac01e173b761bc73d0cf33f4dc1d8d7 SHA512 83c6c0e3ceec149708a8db5d33e95cc84852d8189498c22131c00f4288a6c870f9d522bae9230157f442338dc101e1468451d78dfa274afb83a6f0dd614c8bdb WHIRLPOOL 9617418d6a288d6e57aa1d715498c9adcfbe80cd97a814382431203dab778f26139dc31a14aecfd6f2e71a51f11fe189fce6e3bb7174ce9d4ad25782a9a6fce0
diff --git a/dev-util/bats/bats-0.4.0.ebuild b/dev-util/bats/bats-0.4.0.ebuild
new file mode 100644
index 000000000000..3fa4d97e3843
--- /dev/null
+++ b/dev-util/bats/bats-0.4.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="An automated testing system for bash"
+HOMEPAGE="https://github.com/sstephenson/bats/"
+SRC_URI="https://github.com/sstephenson/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_test() {
+ bin/bats --tap test
+}
+
+src_install() {
+ einstalldocs
+
+ dobin libexec/*
+ doman man/bats.1 man/bats.7
+}
diff --git a/dev-util/bats/metadata.xml b/dev-util/bats/metadata.xml
new file mode 100644
index 000000000000..63003cd5ebcb
--- /dev/null
+++ b/dev-util/bats/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dev+gentoobugzilla@henriksen.is</email>
+ <name>Espen H</name>
+ <description>Proxy maintainer - set to assignee on bugs</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">sstephenson/bats</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ Bats is a TAP-compliant testing framework for Bash. It provides a simple
+ way to verify that the UNIX programs you write behave as expected.
+
+ A Bats test file is a Bash script with special syntax for defining test
+ cases. Under the hood, each test case is just a function with a description.
+
+ Bats is most useful when testing software written in Bash, but you can use
+ it to test any UNIX program.
+ </longdescription>
+</pkgmetadata>