summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2015-08-23 01:44:11 +0100
committerMike Auty <ikelos@gentoo.org>2015-08-23 01:59:38 +0100
commit4ef6927a0a6964ff3ea3fb3df864bb9b356687fb (patch)
treeb43556bbd59a00c74eba99274f7f49b04dbd7eb2 /dev-util/bless/files
parentdev-util/ninja: Copy changes from live ebuild and restore ia64 keyword (diff)
downloadgentoo-4ef6927a0a6964ff3ea3fb3df864bb9b356687fb.tar.gz
gentoo-4ef6927a0a6964ff3ea3fb3df864bb9b356687fb.tar.bz2
gentoo-4ef6927a0a6964ff3ea3fb3df864bb9b356687fb.zip
dev-util/bless: Update for monolithic gtk-sharp & mono-4
Changed the dependencies to cope with the unannounced monolithic gtk-sharp ebuild which blocks on packages such as bless that need glade-sharp. Also introduced a patch to use mcs rather than the depreacted gmcs. Package-Manager: portage-2.2.20.1 Signed-off-by: Mike Auty <ikelos@gentoo.org>
Diffstat (limited to 'dev-util/bless/files')
-rw-r--r--dev-util/bless/files/bless-0.6.0-mono-4.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/bless/files/bless-0.6.0-mono-4.patch b/dev-util/bless/files/bless-0.6.0-mono-4.patch
new file mode 100644
index 000000000000..92b1100cf0e7
--- /dev/null
+++ b/dev-util/bless/files/bless-0.6.0-mono-4.patch
@@ -0,0 +1,36 @@
+diff --git a/builder/ModuleBuilder.cs b/builder/ModuleBuilder.cs
+index 0f62e92..7edb1ab 100644
+--- a/builder/ModuleBuilder.cs
++++ b/builder/ModuleBuilder.cs
+@@ -119,7 +119,7 @@ public class ModuleBuilder
+ //System.Console.WriteLine("gmcs {0}", sb.ToString());
+ System.Console.WriteLine(">> Building module {0}...", module.Name);
+
+- Process buildProcess = Process.Start("gmcs", sb.ToString());
++ Process buildProcess = Process.Start("mcs", sb.ToString());
+ buildProcess.WaitForExit();
+
+ if (buildProcess.ExitCode == 0) {
+@@ -137,4 +137,4 @@ public class ModuleBuilder
+ }
+
+
+-}
+\ No newline at end of file
++}
+diff --git a/configure.ac b/configure.ac
+index 415cc64..a8e527c 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -24,9 +24,9 @@ if test "x$PKG_CONFIG" = "xno"; then
+ fi
+
+ # C# compiler
+-AC_PATH_PROG(MCS, gmcs, no)
++AC_PATH_PROG(MCS, mcs, no)
+
+-CS="gmcs C#"
++CS="mcs C#"
+ if test "x$MCS" = "xno" ; then
+ AC_MSG_ERROR([No $CS compiler found])
+ fi