summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2018-01-16 09:26:15 -0800
committerBrian Dolbec <dolsen@gentoo.org>2018-01-16 09:41:38 -0800
commitaaa5d9e1f21c27b6953cca71daa5d15c3d604901 (patch)
tree8b152f237e3626e50b7fed3df071dd0e9ad5cd4a /dev-util/buildbot-pkg
parentdev-util/buildbot: Version bump, update 9999 ebuild (diff)
downloadgentoo-aaa5d9e1f21c27b6953cca71daa5d15c3d604901.tar.gz
gentoo-aaa5d9e1f21c27b6953cca71daa5d15c3d604901.tar.bz2
gentoo-aaa5d9e1f21c27b6953cca71daa5d15c3d604901.zip
dev-util/buildbot-pkg: Version bump
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-util/buildbot-pkg')
-rw-r--r--dev-util/buildbot-pkg/Manifest1
-rw-r--r--dev-util/buildbot-pkg/buildbot-pkg-0.9.15_p1.ebuild49
-rw-r--r--dev-util/buildbot-pkg/files/buildbot-pkg-0.9.15_p1-Removedevelopmentvirtualenvironmenthack.patch36
3 files changed, 86 insertions, 0 deletions
diff --git a/dev-util/buildbot-pkg/Manifest b/dev-util/buildbot-pkg/Manifest
index 4220057f6145..e7271d698bd8 100644
--- a/dev-util/buildbot-pkg/Manifest
+++ b/dev-util/buildbot-pkg/Manifest
@@ -2,3 +2,4 @@ DIST buildbot-pkg-0.9.10.tar.gz 4422 BLAKE2B bf32d23fa2c2aeb7dab9af84fd095f48a35
DIST buildbot-pkg-0.9.11.tar.gz 4420 BLAKE2B 1930f7416d8037e35603ee2fa7fb739ded5c9a42dcc5f3a4c5b49d49e29932374a369558af9d2c4ef259fe2d016e7c9ee5a31f1a9e520d3c1c77ff5281b14f30 SHA512 63f75f4df2a725caa48d98c09037580c7b6a16609e4063e7aaab8a0e4b7bda4c74da8bf524b7d9a0cf9e909146522af5ffe8f1a5a8617c5f67658cc723f61b2e
DIST buildbot-pkg-0.9.12.tar.gz 4446 BLAKE2B e8077d3b212c968694d2d9e5018c9c985acbff592dbccfeb59543a507f263133268dde57efcacfabb90ea61c3184d34dced21f8e269f619d505166e68c76d43e SHA512 5b9847747924b7e04ae7584f549fa498715e293c6dbdbfef1fe5896c8c96cd65471a908b48c46a32eddbcf8f7b3642402974b4ed3319cf42e90028e772b5e34b
DIST buildbot-pkg-0.9.13.tar.gz 4448 BLAKE2B ea270faafa4a271e11ea1e64191dac0aaf9b6bc08e4d70e71746f9e70eadbe9d70555677bf7e9b264ac9146db0cb1cc639d86194b5280ad53fbe29bf073ee718 SHA512 1cf3ea6237062a0d8c3955ae75b76dd1193ed28c32528f341b242fe6dcc50f4300366474dcdce27246166b35cc1ca31df556b5e6481f5027d073122f1c00362d
+DIST buildbot-pkg-0.9.15.post1.tar.gz 4916 BLAKE2B 17f38dd7c0d70a7d07fde7c53128901dee24bda0d6503bea1dacfbf6f14bba17b645f5067e0932a5f03660330c20f647fe6d4c2125fdbf714a5828de314881bf SHA512 1951de2df02d50ba1d7c3bc6db9084acf65f88a9f9f73bf26715c7d14521403580a26efd8294aa5f2de40b986032dd78fe52230e58ad3d298f39d229481fc286
diff --git a/dev-util/buildbot-pkg/buildbot-pkg-0.9.15_p1.ebuild b/dev-util/buildbot-pkg/buildbot-pkg-0.9.15_p1.ebuild
new file mode 100644
index 000000000000..42d65473d684
--- /dev/null
+++ b/dev-util/buildbot-pkg/buildbot-pkg-0.9.15_p1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit distutils-r1
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="BuildBot common www build tools for packaging releases"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.python.org/pypi/buildbot-pkg"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+
+# No real integration tests for this pkg.
+# all tests are related to making releases and final checks for distribution
+
+RDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}/${P}-Removedevelopmentvirtualenvironmenthack.patch"
+)
+
+python_install_all() {
+ distutils-r1_python_install_all
+}
diff --git a/dev-util/buildbot-pkg/files/buildbot-pkg-0.9.15_p1-Removedevelopmentvirtualenvironmenthack.patch b/dev-util/buildbot-pkg/files/buildbot-pkg-0.9.15_p1-Removedevelopmentvirtualenvironmenthack.patch
new file mode 100644
index 000000000000..ac17539c4e0d
--- /dev/null
+++ b/dev-util/buildbot-pkg/files/buildbot-pkg-0.9.15_p1-Removedevelopmentvirtualenvironmenthack.patch
@@ -0,0 +1,36 @@
+From 6d9f81ec15b7b18f8791981a0d65dc4f266022ca Mon Sep 17 00:00:00 2001
+From: Brian Dolbec <dolsen@gentoo.org>
+Date: Mon, 15 Jan 2018 16:27:54 -0800
+Subject: [PATCH] pkg/buildbot_pkg.py: Remove development virtualenvironment
+ hack
+
+This hack is not needed/nor works reliably in non-virtualenv installs.
+---
+ pkg/buildbot_pkg.py | 11 -----------
+ 1 file changed, 11 deletions(-)
+
+diff --git a/buildbot_pkg.py b/buildbot_pkg.py
+index 89847b040..7788e12d6 100644
+--- a/buildbot_pkg.py
++++ b/buildbot_pkg.py
+@@ -33,17 +33,6 @@ import setuptools.command.build_py
+ import setuptools.command.egg_info
+ from setuptools import setup
+
+-old_listdir = os.listdir
+-
+-
+-def listdir(path):
+- # patch listdir to avoid looking into node_modules
+- l = old_listdir(path)
+- if "node_modules" in l:
+- l.remove("node_modules")
+- return l
+-os.listdir = listdir
+-
+
+ def check_output(cmd):
+ """Version of check_output which does not throw error"""
+--
+2.15.1
+