summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-06-27 14:09:30 -0400
committerZero_Chaos <zerochaos@gentoo.org>2018-06-27 14:10:42 -0400
commit873239607ff9e3dabad29b5b6d3bb2a16e930849 (patch)
treecb56ff8f91d6c8b6cc51f626df35a54850bf168a /dev-util/catalyst/catalyst-9999.ebuild
parentapp-pda/libimobiledevice: Support python3.6 (diff)
downloadgentoo-873239607ff9e3dabad29b5b6d3bb2a16e930849.tar.gz
gentoo-873239607ff9e3dabad29b5b6d3bb2a16e930849.tar.bz2
gentoo-873239607ff9e3dabad29b5b6d3bb2a16e930849.zip
dev-util/catalyst: deps for building bootloader
allow catalyst on x86 and amd64 to build a bootloader from the host instead of requiring a cdtar. these changes are to make sure the needed deps are in place to match the changes in catalyst Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-util/catalyst/catalyst-9999.ebuild')
-rw-r--r--dev-util/catalyst/catalyst-9999.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-util/catalyst/catalyst-9999.ebuild b/dev-util/catalyst/catalyst-9999.ebuild
index c5635f4c74e6..e3bf4c22c44b 100644
--- a/dev-util/catalyst/catalyst-9999.ebuild
+++ b/dev-util/catalyst/catalyst-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -25,7 +25,7 @@ HOMEPAGE="https://wiki.gentoo.org/wiki/Catalyst"
LICENSE="GPL-2"
SLOT="0"
-IUSE="ccache doc kernel_linux"
+IUSE="ccache doc kernel_linux system-bootloader"
DEPEND="
app-text/asciidoc
@@ -44,6 +44,10 @@ RDEPEND="
ccache? ( dev-util/ccache )
kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )
"
+PDEPEND="system-bootloader? ( >=sys-apps/memtest86+-5.01-r4
+ sys-boot/grub:2
+ sys-boot/syslinux
+ sys-boot/shim )"
python_prepare_all() {
python_setup