summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2021-12-30 11:51:18 -0600
committerJohn Helmert III <ajak@gentoo.org>2021-12-30 11:52:31 -0600
commit3d89d0c81148fbcc32c51d084713bd5e731c418f (patch)
treeb0c3be61827a2840afe9e15d4db76d46f698c1db /dev-util/cflow/cflow-1.7.ebuild
parentprofiles/arch/hppa: Unmask python3_10 target (diff)
downloadgentoo-3d89d0c81148fbcc32c51d084713bd5e731c418f.tar.gz
gentoo-3d89d0c81148fbcc32c51d084713bd5e731c418f.tar.bz2
gentoo-3d89d0c81148fbcc32c51d084713bd5e731c418f.zip
dev-util/cflow: add 1.7
Bug: https://bugs.gentoo.org/711196 Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'dev-util/cflow/cflow-1.7.ebuild')
-rw-r--r--dev-util/cflow/cflow-1.7.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-util/cflow/cflow-1.7.ebuild b/dev-util/cflow/cflow-1.7.ebuild
new file mode 100644
index 000000000000..88ed1770ffc6
--- /dev/null
+++ b/dev-util/cflow/cflow-1.7.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common
+
+DESCRIPTION="C function call hierarchy analyzer"
+HOMEPAGE="https://www.gnu.org/software/cflow/"
+SRC_URI="http://ftp.gnu.org/gnu/cflow/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug emacs nls"
+
+RDEPEND="emacs? ( >=app-editors/emacs-23.1:* )
+ nls? ( virtual/libintl virtual/libiconv )"
+BDEPEND="${RDEPEND}
+ sys-devel/flex
+ nls? ( sys-devel/gettext )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ EMACS=no
+}
+
+src_compile() {
+ default
+
+ if use emacs; then
+ elisp-compile elisp/cflow-mode.el
+ fi
+}
+
+src_install() {
+ default
+ doinfo doc/cflow.info
+
+ if use emacs; then
+ elisp-install ${PN} elisp/cflow-mode.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}