summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-04-06 10:32:36 -0400
committerCraig Andrews <candrews@gentoo.org>2018-04-06 10:33:45 -0400
commit02b8d36c0e2d3db75f21668ba1b3869d381b8c0d (patch)
tree1ca45db8c82683170cf4573838355cbe7358e46c /dev-util/clinfo/clinfo-2.2.18.04.06.ebuild
parentdev-ruby/yajl-ruby: amd64 stable (diff)
downloadgentoo-02b8d36c0e2d3db75f21668ba1b3869d381b8c0d.tar.gz
gentoo-02b8d36c0e2d3db75f21668ba1b3869d381b8c0d.tar.bz2
gentoo-02b8d36c0e2d3db75f21668ba1b3869d381b8c0d.zip
dev-util/clinfo: 2.2.18.04.06 version bump
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-util/clinfo/clinfo-2.2.18.04.06.ebuild')
-rw-r--r--dev-util/clinfo/clinfo-2.2.18.04.06.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/clinfo/clinfo-2.2.18.04.06.ebuild b/dev-util/clinfo/clinfo-2.2.18.04.06.ebuild
new file mode 100644
index 000000000000..3d01e885bdad
--- /dev/null
+++ b/dev-util/clinfo/clinfo-2.2.18.04.06.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/Oblomov/clinfo.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/Oblomov/clinfo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A tool to display info about the system's OpenCL capabilities"
+HOMEPAGE="https://github.com/Oblomov/clinfo"
+LICENSE="CC0-1.0"
+SLOT="0"
+
+DEPEND=">=app-eselect/eselect-opencl-1.1.0-r4
+ virtual/opencl"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake MANDIR="${ED}"/usr/share/man PREFIX="${ED}"/usr install
+}