summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-02-21 16:50:54 -0500
committerCraig Andrews <candrews@gentoo.org>2021-02-21 16:52:37 -0500
commit94792327c368fe15e2eebe9d22f11821de9fc02b (patch)
treee280b8376430faa0c34077b1d7e883ecb7fd8827 /dev-util/clinfo/clinfo-3.0.21.02.21.ebuild
parentnet-wireless/soapyuhd: remove whitespace (diff)
downloadgentoo-94792327c368fe15e2eebe9d22f11821de9fc02b.tar.gz
gentoo-94792327c368fe15e2eebe9d22f11821de9fc02b.tar.bz2
gentoo-94792327c368fe15e2eebe9d22f11821de9fc02b.zip
dev-util/clinfo: 3.0.21.02.21 version bump
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-util/clinfo/clinfo-3.0.21.02.21.ebuild')
-rw-r--r--dev-util/clinfo/clinfo-3.0.21.02.21.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/clinfo/clinfo-3.0.21.02.21.ebuild b/dev-util/clinfo/clinfo-3.0.21.02.21.ebuild
new file mode 100644
index 000000000000..d215bb747829
--- /dev/null
+++ b/dev-util/clinfo/clinfo-3.0.21.02.21.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/Oblomov/clinfo.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/Oblomov/clinfo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A tool to display info about the system's OpenCL capabilities"
+HOMEPAGE="https://github.com/Oblomov/clinfo"
+LICENSE="CC0-1.0"
+SLOT="0"
+
+DEPEND=">=virtual/opencl-3"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake MANDIR="${ED}"/usr/share/man PREFIX="${ED}"/usr install
+}