summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-01-25 10:50:04 -0500
committerCraig Andrews <candrews@gentoo.org>2023-01-25 10:51:20 -0500
commit436072e7b1f661ed2c5232edb0103ae00772ddb2 (patch)
treedbae1b0a912b26d8f1535fcc041e9d8e736b8c93 /dev-util/clinfo/clinfo-3.0.23.01.25.ebuild
parentxfce-base/xfdesktop: keyword 4.19.0 for ~loong (diff)
downloadgentoo-436072e7b1f661ed2c5232edb0103ae00772ddb2.tar.gz
gentoo-436072e7b1f661ed2c5232edb0103ae00772ddb2.tar.bz2
gentoo-436072e7b1f661ed2c5232edb0103ae00772ddb2.zip
dev-util/clinfo: add 3.0.23.01.25
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-util/clinfo/clinfo-3.0.23.01.25.ebuild')
-rw-r--r--dev-util/clinfo/clinfo-3.0.23.01.25.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/clinfo/clinfo-3.0.23.01.25.ebuild b/dev-util/clinfo/clinfo-3.0.23.01.25.ebuild
new file mode 100644
index 000000000000..92b64abc9e31
--- /dev/null
+++ b/dev-util/clinfo/clinfo-3.0.23.01.25.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/Oblomov/clinfo.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/Oblomov/clinfo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A tool to display info about the system's OpenCL capabilities"
+HOMEPAGE="https://github.com/Oblomov/clinfo"
+LICENSE="CC0-1.0"
+SLOT="0"
+
+DEPEND=">=virtual/opencl-3"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake MANDIR="${ED}"/usr/share/man PREFIX="${ED}"/usr install
+}