summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRolf Eike Beer <eike@sf-mail.de>2018-03-09 21:05:35 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-03-12 16:32:27 +0100
commite92084cc3d3ce917eee875e3e16da54cc6f329a5 (patch)
tree00baa8150806b95cdce345cf613dee01740bb5de /dev-util/cmake
parentwww-client/qutebrowser: bump 1.2.0 (diff)
downloadgentoo-e92084cc3d3ce917eee875e3e16da54cc6f329a5.tar.gz
gentoo-e92084cc3d3ce917eee875e3e16da54cc6f329a5.tar.bz2
gentoo-e92084cc3d3ce917eee875e3e16da54cc6f329a5.zip
dev-util/cmake: simplify FindBLAS patch
Most of the previous Gentoo patch has been upstreamed. Closes: https://github.com/gentoo/gentoo/pull/7409
Diffstat (limited to 'dev-util/cmake')
-rw-r--r--dev-util/cmake/cmake-3.11.0_rc3.ebuild2
-rw-r--r--dev-util/cmake/files/cmake-3.11.0_rc2-FindBLAS.patch23
2 files changed, 24 insertions, 1 deletions
diff --git a/dev-util/cmake/cmake-3.11.0_rc3.ebuild b/dev-util/cmake/cmake-3.11.0_rc3.ebuild
index ebda7cc29ddc..61e5d0065112 100644
--- a/dev-util/cmake/cmake-3.11.0_rc3.ebuild
+++ b/dev-util/cmake/cmake-3.11.0_rc3.ebuild
@@ -51,7 +51,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-3.1.0-darwin-isysroot.patch
# handle gentoo packaging in find modules
- "${FILESDIR}"/${PN}-3.0.0-FindBLAS.patch
+ "${FILESDIR}"/${PN}-3.11.0_rc2-FindBLAS.patch
"${FILESDIR}"/${PN}-3.8.0_rc2-FindBoost-python.patch
"${FILESDIR}"/${PN}-3.0.2-FindLAPACK.patch
"${FILESDIR}"/${PN}-3.5.2-FindQt4.patch
diff --git a/dev-util/cmake/files/cmake-3.11.0_rc2-FindBLAS.patch b/dev-util/cmake/files/cmake-3.11.0_rc2-FindBLAS.patch
new file mode 100644
index 000000000000..6bad45b20876
--- /dev/null
+++ b/dev-util/cmake/files/cmake-3.11.0_rc2-FindBLAS.patch
@@ -0,0 +1,23 @@
+--- a/Modules/FindBLAS.cmake
++++ b/Modules/FindBLAS.cmake
+@@ -4,6 +4,10 @@
+ #
+ # Find BLAS library
+ #
++# Version modified for Gentoo Linux.
++# If a valid PkgConfig configuration is found, this overrides and cancels
++# all further checks.
++#
+ # This module finds an installed fortran library that implements the
+ # BLAS linear-algebra interface (see http://www.netlib.org/blas/). The
+ # list of libraries searched for is taken from the autoconf macro file,
+@@ -50,6 +54,9 @@
+ # (To distribute this file outside of CMake, substitute the full
+ # License text for the above reference.)
+
++# first, try PkgConfig
++set(BLA_PREFER_PKGCONFIG On)
++
+ include(${CMAKE_CURRENT_LIST_DIR}/CheckFunctionExists.cmake)
+ include(${CMAKE_CURRENT_LIST_DIR}/CheckFortranFunctionExists.cmake)
+