summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-08-24 11:17:18 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-08-24 11:17:18 +0200
commit4bab5a70685157e097c458cc5782ac8afef8b321 (patch)
tree9ad46be0fd72b1ed19cb0eb50b3b098115687a08 /dev-util/coccinelle
parentnet-misc/rabbitmq-server: Version bump (bug 558536). (diff)
downloadgentoo-4bab5a70685157e097c458cc5782ac8afef8b321.tar.gz
gentoo-4bab5a70685157e097c458cc5782ac8afef8b321.tar.bz2
gentoo-4bab5a70685157e097c458cc5782ac8afef8b321.zip
dev-util/coccinelle: bump to 1.0.2.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-util/coccinelle')
-rw-r--r--dev-util/coccinelle/Manifest1
-rw-r--r--dev-util/coccinelle/coccinelle-1.0.2.ebuild132
2 files changed, 133 insertions, 0 deletions
diff --git a/dev-util/coccinelle/Manifest b/dev-util/coccinelle/Manifest
index 9a217321114..5184a326723 100644
--- a/dev-util/coccinelle/Manifest
+++ b/dev-util/coccinelle/Manifest
@@ -1,2 +1,3 @@
DIST coccinelle-1.0.0.tgz 3427246 SHA256 e18b4c77964c6f623c385dc8b2fcb46beacd9811927617144620b12d93289e74 SHA512 0c59918dff3d33035f5c928b54de9cbe32f9146d9e4b82545d168140d1395ff5b3e446faff47f39dbb6fceb74f432b419e9c7322e834c11bb50b5fb5d4e4dd46 WHIRLPOOL 8714327d7156bd1ada0c6b0776fefcc4e46b9885354ca686d4de8b35c2dd1cf6372e91dfa3a04645295f411b40d57eee94d81cbd8dfe2c18f3dc3b15ff8e1926
DIST coccinelle-1.0.1.tgz 2772730 SHA256 39caac46c1f80cbe5de21164c5b31a794e3befdb9cd7ef1d080d455ac171b526 SHA512 5a69476941a9582ca6e0663c468a87aba15b6e38243cbb532c517b75066c8fafe37cbe6d398d6183cc7a315c5680efdf425f0bc8cb2184dbf94e446879514a89 WHIRLPOOL 8b38b982b8d19c10c7e3ed77629b6883c4d6455da4da4d68251b492ce36490c5236573bf7c44a34e21887b8be0ca83b4efb39cf13b1c4c6db7db58979ee6a7bc
+DIST coccinelle-1.0.2.tgz 2790829 SHA256 4e45b904f42c9b84732168782d491c8c1ab23bb85db06c4b9ba2762bea8ac679 SHA512 83c8e250a7e19126ce3f95d0455892d60b2d7a688af3a066edcfb9a8cc146f8a9281c9e019896421e1bc546d366114effef3116105eae19617ad45c26f42c534 WHIRLPOOL 15b64abbad31f49883e4cacc2282ed28eb67f64d951636ee6b690a474b072e6a029c4131adb727f5f7a8d86628b871db0cff144ad8478514529c4c5d5dee9074
diff --git a/dev-util/coccinelle/coccinelle-1.0.2.ebuild b/dev-util/coccinelle/coccinelle-1.0.2.ebuild
new file mode 100644
index 00000000000..adc67ae5c72
--- /dev/null
+++ b/dev-util/coccinelle/coccinelle-1.0.2.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit multilib eutils python-single-r1 bash-completion-r1 elisp-common autotools
+
+MY_P="${P/_/-}"
+DESCRIPTION="Program matching and transformation engine"
+HOMEPAGE="http://coccinelle.lip6.fr/"
+SRC_URI="http://coccinelle.lip6.fr/distrib/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc emacs ocaml +ocamlopt pcre python test vim-syntax"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# ocaml enables ocaml scripting (uses findlib)
+CDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
+ dev-ml/sexplib:=[ocamlopt?]
+ dev-ml/menhir:=[ocamlopt?]
+ || ( dev-ml/camlp4:=[ocamlopt?] <dev-lang/ocaml-4.02.0 )
+ dev-ml/parmap:=[ocamlopt?]
+ emacs? ( virtual/emacs )
+ ocaml? ( dev-ml/findlib:= )
+ pcre? ( dev-ml/pcre-ocaml:=[ocamlopt?] )
+ python? ( ${PYTHON_DEPS} )"
+
+RDEPEND="${CDEPEND}
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
+
+# dev-texlive/texlive-fontsextra contains 'ifsym.sty'
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-fontsextra
+ )"
+
+REQUIRED_USE="test? ( ocaml python )"
+
+DOCS=( authors.txt bugs.txt changes.txt credits.txt readme.txt )
+
+S=${WORKDIR}/${MY_P}
+
+SITEFILE=50coccinelle-gentoo.el
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ if use python ; then
+ # fix python install location
+ sed -e "s:\$(LIBDIR)/python:$(python_get_sitedir):" \
+ -i Makefile || die
+ fi
+
+ # This is regenerated by menhir, bundled version does not build with latest
+ # one...
+ rm -f parsing_cocci/parser_cocci_menhir.ml
+
+ epatch "${FILESDIR}"/${PN}-1.0.0_rc16-findtool.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable python) \
+ $(use_enable ocaml) \
+ $(use_enable pcre) \
+ $(use_enable pcre pcre-syntax)
+}
+
+src_compile() {
+ emake depend
+ emake
+
+ use ocamlopt && emake opt
+
+ if use doc ; then
+ VARTEXFONTS="${T}"/fonts emake docs
+ fi
+
+ if use emacs ; then
+ elisp-compile editors/emacs/cocci.el || die
+ fi
+}
+
+src_test() {
+ source env.sh # needed for built in-place python plugin
+ ./spatch standard.h -parse_c -dir tests/ || die
+ yes | ./spatch -iso_file standard.iso -macro_file_builtins standard.h -testall || die
+ if use ocamlopt ; then
+ ./spatch.opt -iso_file standard.iso -macro_file_builtins standard.h -testall || die
+ fi
+}
+
+src_install() {
+ default
+
+ use doc && dodoc docs/manual/*.pdf
+ newbashcomp scripts/spatch.bash_completion spatch
+
+ if use emacs ; then
+ elisp-install ${PN} editors/emacs/*
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
+
+ if use vim-syntax ; then
+ newdoc editors/vim/README README-vim
+ rm editors/vim/README || die
+ insinto /usr/share/vim/vimfiles
+ doins -r editors/vim/*
+ fi
+
+ use python && python_optimize
+
+ export STRIP_MASK='*/coccinelle/spatch'
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}