summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-16 14:00:41 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-16 14:00:48 +0100
commit79701d2071c5bbf4817702588569cad2c55da28e (patch)
tree57d9a12a35dc04293530724a565fc294b372d886 /dev-util/cppunit
parentdev-util/cppunit: Bump to version 1.15.1 (diff)
downloadgentoo-79701d2071c5bbf4817702588569cad2c55da28e.tar.gz
gentoo-79701d2071c5bbf4817702588569cad2c55da28e.tar.bz2
gentoo-79701d2071c5bbf4817702588569cad2c55da28e.zip
dev-util/cppunit: Synced live ebuild
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-util/cppunit')
-rw-r--r--dev-util/cppunit/cppunit-9999.ebuild43
1 files changed, 23 insertions, 20 deletions
diff --git a/dev-util/cppunit/cppunit-9999.ebuild b/dev-util/cppunit/cppunit-9999.ebuild
index 435544298bf8..a03be99e2df6 100644
--- a/dev-util/cppunit/cppunit-9999.ebuild
+++ b/dev-util/cppunit/cppunit-9999.ebuild
@@ -1,25 +1,26 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/cppunit.git"
-[[ ${PV} = 9999 ]] && inherit git-r3 autotools
inherit flag-o-matic multilib-minimal
DESCRIPTION="C++ port of the famous JUnit framework for unit testing"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/cppunit"
-[[ ${PV} = 9999 ]] || SRC_URI="https://dev-www.libreoffice.org/src/${P}.tar.gz"
-
+if [[ "${PV}" == *9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/cppunit.git"
+else
+ SRC_URI="https://dev-www.libreoffice.org/src/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+fi
LICENSE="LGPL-2.1"
SLOT="0"
-# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
-[[ ${PV} = 9999 ]] || \
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="doc examples static-libs"
RDEPEND=""
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
doc? (
app-doc/doxygen[dot]
media-gfx/graphviz
@@ -27,11 +28,11 @@ DEPEND="${RDEPEND}
"
DOCS=( AUTHORS BUGS NEWS README THANKS TODO doc/FAQ )
-[[ ${PV} = 9999 ]] || DOCS+=( ChangeLog )
+[[ "${PV}" == 9999 ]] || DOCS+=( ChangeLog )
src_prepare() {
default
- [[ ${PV} = 9999 ]] && eautoreconf
+ [[ "${PV}" == 9999 ]] && eautoreconf
}
src_configure() {
@@ -42,22 +43,24 @@ src_configure() {
}
multilib_src_configure() {
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable static-libs static) \
- $(multilib_native_use_enable doc doxygen) \
- $(multilib_native_use_enable doc dot) \
+ local myeconfargs=(
--disable-werror
+ $(multilib_native_use_enable doc dot)
+ $(multilib_native_use_enable doc doxygen)
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_install_all() {
- if use doc; then
- mv "${ED%/}"/usr/share/${PN}/html "${ED%/}"/usr/share/doc/${PF} || die
- rm -r "${ED%/}"/usr/share/${PN} || die
+ if use doc ; then
+ mv "${ED}"/usr/share/${PN}/html "${ED}"/usr/share/doc/${PF} \
+ || die
+ rm -r "${ED}"/usr/share/${PN} || die
fi
einstalldocs
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
if use examples ; then
find examples -iname "*.o" -delete