summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-09-28 19:00:10 +0200
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-10-02 23:27:07 -0700
commit35cf3b9c6cf0cc42c7c83df4202939bbbccce387 (patch)
treec5fe6de5be0dd6c907e129d1870089a1a38f31a7 /dev-util/cpputest
parentdev-vcs/tig: restore tab completion (diff)
downloadgentoo-35cf3b9c6cf0cc42c7c83df4202939bbbccce387.tar.gz
gentoo-35cf3b9c6cf0cc42c7c83df4202939bbbccce387.tar.bz2
gentoo-35cf3b9c6cf0cc42c7c83df4202939bbbccce387.zip
dev-util/cpputest: bump to 4.0
Closes: https://bugs.gentoo.org/724254 Closes: https://bugs.gentoo.org/727324 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-util/cpputest')
-rw-r--r--dev-util/cpputest/Manifest1
-rw-r--r--dev-util/cpputest/cpputest-4.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/cpputest/Manifest b/dev-util/cpputest/Manifest
index 67b6d284fe06..05c8565c0dbb 100644
--- a/dev-util/cpputest/Manifest
+++ b/dev-util/cpputest/Manifest
@@ -1 +1,2 @@
DIST cpputest-3.8.tar.gz 2722956 BLAKE2B 1da16c06d242703462dcaf9c6c26eb875c2622bcce4113fd0b990805d06ee7401a6776d2f0451eda49e7914caa59a5665a92387684ffb6dbbe884cf0fe07bd86 SHA512 a9592bdc9ffab8b42026ef2010f504e7e37d77fc2f197f89d23f7c9285a101059a0ec66418b914db0383974616d31b26addd1938fb27f45c3e7d9496ed0a0fac
+DIST cpputest-4.0.tar.gz 1163749 BLAKE2B 2ae0f4658662ead0fe5a46a0ae521edf7677a7b64e3c7ce9bad374c4f953ea5a548cdfe1d9128821ab5031211c10f02d0728085e68db02e0d021ea16d8b38f1c SHA512 69f39fffdcd965c871e598118db38ddb74a3e75fd7a7965f8d236029fa891f6fcb6b671147c166ad08482bbd0737537fafe90aa8439a0ab62389f19150cc39d7
diff --git a/dev-util/cpputest/cpputest-4.0.ebuild b/dev-util/cpputest/cpputest-4.0.ebuild
new file mode 100644
index 000000000000..1288ed85d9d4
--- /dev/null
+++ b/dev-util/cpputest/cpputest-4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Unit testing and mocking framework for C/C++"
+HOMEPAGE="https://cpputest.github.io/ https://github.com/cpputest/cpputest"
+SRC_URI="https://github.com/cpputest/cpputest/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( >=dev-cpp/gtest-1.8.0 )"
+
+DOCS=( AUTHORS README.md README_CppUTest_for_C.txt )
+
+src_prepare() {
+ default
+ eautoreconf
+}