summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-11 06:29:12 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-11 06:39:35 -0400
commit536705035512808ac19addaf703e23bb55adfc71 (patch)
tree3d7d452c2f120c2b5b6be971e92e5dcd63aaf01a /dev-util/cutils/cutils-1.6-r4.ebuild
parentsys-devel/clang: Remove unnecessary LLVM_EXTERNAL_LIT hack (diff)
downloadgentoo-536705035512808ac19addaf703e23bb55adfc71.tar.gz
gentoo-536705035512808ac19addaf703e23bb55adfc71.tar.bz2
gentoo-536705035512808ac19addaf703e23bb55adfc71.zip
dev-util/cutils: EAPI7->8, fix direct AR and build w/ clang16
Closes: https://bugs.gentoo.org/724270 Closes: https://bugs.gentoo.org/871402 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-util/cutils/cutils-1.6-r4.ebuild')
-rw-r--r--dev-util/cutils/cutils-1.6-r4.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/dev-util/cutils/cutils-1.6-r4.ebuild b/dev-util/cutils/cutils-1.6-r4.ebuild
deleted file mode 100644
index a7b7e983a7b2..000000000000
--- a/dev-util/cutils/cutils-1.6-r4.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="C language utilities"
-HOMEPAGE="http://www.sigala.it/sandro/software.php#cutils"
-SRC_URI="http://www.sigala.it/sandro/files/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-
-BDEPEND="sys-devel/flex"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-infopage.patch
- "${FILESDIR}"/${P}-case-insensitive.patch
-)
-
-src_prepare() {
- default
-
- mv src/cdecl/{,cutils-}cdecl.1 || die
-
- # delete pointless README
- rm README.compile || die
-
- # Force rebuild of cutils.info
- rm doc/cutils.info || die
-
- sed -e "s/cdecl/cutils-cdecl/g" \
- -i doc/cutils.texi || die
- sed -e "/PROG/s/cdecl/cutils-cdecl/" \
- -i src/cdecl/Makefile.in || die
- sed -e "/Xr/s/cdecl/cutils-cdecl/" \
- -i src/cundecl/cundecl.1 || die
- sed -e "/Nm/s/cdecl/cutils-cdecl/" \
- -i src/cdecl/cutils-cdecl.1 || die
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" -j1
-}
-
-src_install() {
- default
- dodoc HISTORY
-}
-
-pkg_postinst() {
- elog "cdecl was installed as cutils-cdecl because of a naming conflict"
- elog "with dev-util/cdecl."
-}