summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTact Yoshida <otakuto.gentoo@gmail.com>2018-07-17 08:13:28 +0900
committerTony Vroon <chainsaw@gentoo.org>2018-07-17 17:06:48 +0100
commit8b13e9ccaa02b2bae9ab69f0129cc98e3f420946 (patch)
tree53f71321cdafbfcefe5b2f1fe74f6d7dafd1c045 /dev-util/cutter
parentdev-ruby/facter: 3.11.3 bup (diff)
downloadgentoo-8b13e9ccaa02b2bae9ab69f0129cc98e3f420946.tar.gz
gentoo-8b13e9ccaa02b2bae9ab69f0129cc98e3f420946.tar.bz2
gentoo-8b13e9ccaa02b2bae9ab69f0129cc98e3f420946.zip
dev-util/cutter: bump to 1.6
Package-Manager: Portage-2.3.40, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9257
Diffstat (limited to 'dev-util/cutter')
-rw-r--r--dev-util/cutter/Manifest1
-rw-r--r--dev-util/cutter/cutter-1.6.ebuild46
-rw-r--r--dev-util/cutter/files/cutter-1.6-python3-config.patch20
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-util/cutter/Manifest b/dev-util/cutter/Manifest
index 26f360c427ee..e13009f0b8b1 100644
--- a/dev-util/cutter/Manifest
+++ b/dev-util/cutter/Manifest
@@ -1,2 +1,3 @@
DIST cutter-1.0.tar.gz 614826 BLAKE2B 8f75343e57bf986d80dde3dc3ceb59675d28854744d8cc5fac783514e9c200595990d4860ee45db6544537d4f367df5b62a034e298bf273e44302edfa1647c84 SHA512 af6be59be7871d21d4f665e8ecb7f8224d99ccf7d62793e989ccd780ee521641c6ec0d941b46bb82770f5d44e5c0ef2efc29f9be303385e8e757e62a54bf53b1
DIST cutter-1.4.tar.gz 1067162 BLAKE2B 2f7eceffcfb3c542695e03ec72de1c99451f8278e91f50abc2e87542efbd2cc73d5a52b0e5303b9cea751edf91bc71b63295edd5b32d1b2b9ed3a1443cfc92e7 SHA512 54caec67e57f2ff3908942c1ebd1e909c65204c6f31d0ec95e31f46e03364f309898006b93555ba81287c0d74faf407272226e5ec65b3148ecde8feec11ca3be
+DIST cutter-1.6.tar.gz 1083427 BLAKE2B d51b88f2b9dd2655ef58d7075086959ec3ed59ed4b21db81a792ee165deda523a4e59378c954d0f2aa5b0af25d67329ed2119c004edc402c9b593a3b230a6fd9 SHA512 83aaadfbaccdaa514606408868c050e22d0a80a749b98a9f6df929467a16e69b0d454b25ce1cf53e35ebbfb74e9b39e2bd390057488c9bb3992a442ca306c2f1
diff --git a/dev-util/cutter/cutter-1.6.ebuild b/dev-util/cutter/cutter-1.6.ebuild
new file mode 100644
index 000000000000..58addf198122
--- /dev/null
+++ b/dev-util/cutter/cutter-1.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="A Qt and C++ GUI for radare2 reverse engineering framework"
+HOMEPAGE="https://www.radare.org"
+SRC_URI="https://github.com/radareorg/cutter/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="jupyter webengine"
+REQUIRED_USE="webengine? ( jupyter )"
+
+DEPEND="
+ >=dev-qt/qtcore-5.9.1:5
+ >=dev-qt/qtgui-5.9.1:5
+ >=dev-qt/qtsvg-5.9.1:5
+ >=dev-qt/qtwidgets-5.9.1:5
+ >=dev-util/radare2-2.7.0
+ jupyter? ( dev-python/jupyter )
+ webengine? ( >=dev-qt/qtwebengine-5.9.1:5[widgets] )
+"
+
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-python3-config.patch"
+)
+
+src_configure() {
+ local myqmakeargs=(
+ CUTTER_ENABLE_JUPYTER=$(usex jupyter true false)
+ CUTTER_ENABLE_QTWEBENGINE=$(usex webengine true false)
+ PREFIX=\'${EPREFIX}/usr\'
+ )
+
+ eqmake5 "${myqmakeargs[@]}" src
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
diff --git a/dev-util/cutter/files/cutter-1.6-python3-config.patch b/dev-util/cutter/files/cutter-1.6-python3-config.patch
new file mode 100644
index 000000000000..51a811dbb33f
--- /dev/null
+++ b/dev-util/cutter/files/cutter-1.6-python3-config.patch
@@ -0,0 +1,20 @@
+--- a/src/Cutter.pro 2018-04-24 17:43:11.000000000 +0900
++++ b/src/Cutter.pro 2018-07-08 21:21:34.280748499 +0900
+@@ -74,11 +74,13 @@
+ LIBS += -F$$PYTHON_FRAMEWORK_DIR -framework Python
+ DEFINES += MACOS_PYTHON_FRAMEWORK_BUNDLED
+ } else {
+- CONFIG += link_pkgconfig
+- !packagesExist(python3) {
+- error("ERROR: Python 3 could not be found. Make sure it is available to pkg-config.")
++ system(type python3-config) {
++ LIBS += $$system(python3-config --libs)
++ TMP = $$system(python3-config --includes)
++ INCLUDEPATH += $$replace(TMP, "-I", "")
++ } else {
++ error("ERROR: Python 3 could not be found. Make sure it is available to python3-config.")
+ }
+- PKGCONFIG += python3
+ }
+ }
+