summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-08-15 21:12:18 +0200
committerJeroen Roovers <jer@gentoo.org>2018-08-15 21:17:29 +0200
commit175e12d3385b106a7849ba5fcd7c496af7ba31f7 (patch)
tree2974a8e44c8e804b02c800e86855aab70787291b /dev-util/debootstrap
parentkde-frameworks/kirigami: Switch to KDE_TEST=true (diff)
downloadgentoo-175e12d3385b106a7849ba5fcd7c496af7ba31f7.tar.gz
gentoo-175e12d3385b106a7849ba5fcd7c496af7ba31f7.tar.bz2
gentoo-175e12d3385b106a7849ba5fcd7c496af7ba31f7.zip
dev-util/debootstrap: Version 1.0.107.
Package-Manager: Portage-2.3.46, Repoman-2.3.10
Diffstat (limited to 'dev-util/debootstrap')
-rw-r--r--dev-util/debootstrap/Manifest1
-rw-r--r--dev-util/debootstrap/debootstrap-1.0.107.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/debootstrap/Manifest b/dev-util/debootstrap/Manifest
index 102d414e64df..1a92b9dfa4a9 100644
--- a/dev-util/debootstrap/Manifest
+++ b/dev-util/debootstrap/Manifest
@@ -1,5 +1,6 @@
DIST debootstrap_1.0.103.tar.gz 73167 BLAKE2B 063e27c1d58826bb7fec7879a5876df33b0da27cdbbdce3aa5ffecbcb70dba2814817e644725a132100cc7c7d182576bb2ba813f96bb4b289d06622d073da9d3 SHA512 4b43db32c46e5b69db9885494bc1f91197a40311c05196bf1c6e17d0a1f0519dbf61c8f5731c8627a708b8dfc8f3ba78e822a21879a5caf0d70046e3b7e60aa2
DIST debootstrap_1.0.104.tar.gz 73264 BLAKE2B 28b4d1d1ad389dfb13f049529e5d14e1d8d82abf58b802ff25787e5c791c5d25aa2fd349f923b4e4d29bcbed78f2d32769189e110b6788acb67fb5499454dc52 SHA512 cfefa225a804e353195dedf5fbf0b005e7ac988f66c934927a312a32e8bbe9fd1083647fbafc5dbb3c7b55613887beb2c6296e3a5b8ed705b9ce18e850ee27a4
DIST debootstrap_1.0.106.tar.gz 73686 BLAKE2B c6dbaa19ab702e49117b56ed04928f0ba6656ee9af8f206ae376af72baf114b20175b32e1c6d6b2fbc7b851e204445b4758a0edc147b94c687ddb5bca8457252 SHA512 86eee4ea1782cd96f364df748b3c7c62a48728c3371fe708937ebb76d75d0ad967d76af7a7f6cc1eb7a8623bba817137b49ffe145378489126d38021dd2882b2
+DIST debootstrap_1.0.107.tar.gz 74202 BLAKE2B 672f4bd723bec5d77d4bf6a5e38b9092cccb890141a44c67d8e8e63e35be3e3735e348b82052090e748d39ad025d73e18ca939c1b040be30af760cdbb8e8df81 SHA512 5b166351c590918cb913ab2307b61c5e6e257c7227e04881ff91d9a579db32c2da920a590ae3471821513eded9bf517feee97bedf43b7feb2ea7f1c5308b873f
DIST debootstrap_1.0.89.tar.gz 69020 BLAKE2B 9175d0936b6c9a28a29ee1b24bd835c41aaf807bc24a029201aaa45d07789206ee06e38b0a70c1e507ab448a3ec9c0fded2838bfb868334270b5159b34cbe9eb SHA512 3f230ce3eff6359353d106c806ce395861fb47fc1416eb0b498af7ce12a45ce7572b18284633d6d4d07b73a4a203e03bc205df3eae0db6f637237d25d0a69b1a
DIST devices.tar.gz 47835 BLAKE2B 03bfe097fda12a7a0aa19d3308c0d44382ad945defea05a63b17a72e4051ef94f0e60e75bde35baeace81da59d9f04126f6e463163609475b9c0fdf518f533ef SHA512 994ec8d72e3d52d2d872f7ff0da2336e4cbd3a5fa73bb6cdb9e06f5e7f5b8c69cea639c738fdba1186f382d6dcf62e7746fface664bfbd744aac24b16f034432
diff --git a/dev-util/debootstrap/debootstrap-1.0.107.ebuild b/dev-util/debootstrap/debootstrap-1.0.107.ebuild
new file mode 100644
index 000000000000..93ffd5d2d1aa
--- /dev/null
+++ b/dev-util/debootstrap/debootstrap-1.0.107.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Debian/Ubuntu bootstrap scripts"
+HOMEPAGE="https://packages.qa.debian.org/d/debootstrap.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.gz
+ mirror://gentoo/devices.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ app-arch/dpkg
+ net-misc/wget
+ sys-devel/binutils
+"
+DOCS=( TODO debian/changelog )
+
+src_unpack() {
+ unpack ${PN}_${PV}.tar.gz
+ cp "${DISTDIR}"/devices.tar.gz "${S}"
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ default
+ doman debootstrap.8
+}
+
+pkg_postinst() {
+ if ! has_version ${CATEGORY}/${PN} && ! has_version app-crypt/gnupg; then
+ elog "To check Release files against a keyring (--keyring=K), please"
+ elog "install app-crypt/gnupg"
+ fi
+
+ if ! has_version app-crypt/debian-archive-keyring || ! has_version app-crypt/ubuntu-keyring; then
+ elog "To check Release files from Debian or Ubuntu, please install"
+ elog " app-crypt/debian-archive-keyring or"
+ elog " app-crypt/ubuntu-keyring as required"
+ fi
+}