summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-06-25 12:13:14 +0200
committerPacho Ramos <pacho@gentoo.org>2016-06-25 14:20:17 +0200
commitcdce0f3b462f6fc34b56a0ceee6a9c46cc45fa5b (patch)
treeceb4dfe1ed8859ee3327152d7071005f577af7cd /dev-util/devhelp
parentdev-util/devhelp: Drop old (diff)
downloadgentoo-cdce0f3b462f6fc34b56a0ceee6a9c46cc45fa5b.tar.gz
gentoo-cdce0f3b462f6fc34b56a0ceee6a9c46cc45fa5b.tar.bz2
gentoo-cdce0f3b462f6fc34b56a0ceee6a9c46cc45fa5b.zip
dev-util/devhelp: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-util/devhelp')
-rw-r--r--dev-util/devhelp/Manifest1
-rw-r--r--dev-util/devhelp/devhelp-3.20.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-util/devhelp/Manifest b/dev-util/devhelp/Manifest
index 1841795fd0d0..97c01b74e8fd 100644
--- a/dev-util/devhelp/Manifest
+++ b/dev-util/devhelp/Manifest
@@ -1 +1,2 @@
DIST devhelp-3.18.1.tar.xz 464312 SHA256 303a162ad294dc6f9984898e501a06dc5d2aa9812b06801c2e39b250d8c51aef SHA512 7b3eca28f1e6117e2aa0599645fec8e1b18f05c44d8f79de7f7de6804bdf485034515ff6bdd9599810ba9880c8eac0901ba5d29b8272a061196cfc5bd563eb79 WHIRLPOOL 284a3ec2548429a5ee7ebce5eb38e586737d71430a19777e1e05c634c011bbc173ddcaf7f4cf24f3e2e68965b117b5c4f0228467cd080c15e4ab05385b468a47
+DIST devhelp-3.20.0.tar.xz 489308 SHA256 a23375c2e2b2ef6240994bc2327fcacfd42403af6d872d0cba2e16dd45ca1f1d SHA512 4f64d95bddc41031a4c7589fdd6ed15b17654917c82a77b82044d5c7ac7bf02546ac1d689a6909bb5128f125a992910ccb4eb0c0e261ffa94eea0f0fef39316b WHIRLPOOL 41d015394f0a5f8e4757c6aae09f74b3e902f2ad8753face16041e850e72b176629eb6f733de97272f6dc42d51f4ebae1c5cad875f419b4df2ddec7e5d56f0bd
diff --git a/dev-util/devhelp/devhelp-3.20.0.ebuild b/dev-util/devhelp/devhelp-3.20.0.ebuild
new file mode 100644
index 000000000000..e609018a7eb5
--- /dev/null
+++ b/dev-util/devhelp/devhelp-3.20.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+# gedit-3.8 is python3 only, this also per:
+# https://bugzilla.redhat.com/show_bug.cgi?id=979450
+PYTHON_COMPAT=( python{3_3,3_4,3_5} )
+
+inherit gnome2 python-single-r1 toolchain-funcs
+
+DESCRIPTION="An API documentation browser for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Devhelp"
+
+LICENSE="GPL-2+"
+SLOT="0/3-1" # subslot = 3-(libdevhelp-3 soname version)
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="gedit"
+REQUIRED_USE="gedit? ( ${PYTHON_REQUIRED_USE} )"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.37.3:2[dbus]
+ >=x11-libs/gtk+-3.19.3:3
+ >=net-libs/webkit-gtk-2.6.0:4
+"
+RDEPEND="${COMMON_DEPEND}
+ gedit? (
+ ${PYTHON_DEPS}
+ app-editors/gedit[introspection,python,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+[introspection] )
+ gnome-base/gsettings-desktop-schemas
+"
+DEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+"
+pkg_setup() {
+ use gedit && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ if ! use gedit ; then
+ sed -e '/SUBDIRS/ s/gedit-plugin//' -i misc/Makefile.{am,in} || die
+ fi
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf=""
+ # ICC is crazy, silence warnings (bug #154010)
+ if [[ $(tc-getCC) == "icc" ]] ; then
+ myconf="--with-compile-warnings=no"
+ fi
+ gnome2_src_configure ${myconf}
+}