summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2017-07-19 19:43:16 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-07-20 23:37:17 +0200
commit4da8a95f7e3613f37d8fd3b764cc93e7ef2531a1 (patch)
tree8f2f3a6c0331a9984b1d7c10720d9bc427923809 /dev-util/geany-plugins
parentsci-libs/gdal: ia64 keyworded, bug #555510 (diff)
downloadgentoo-4da8a95f7e3613f37d8fd3b764cc93e7ef2531a1.tar.gz
gentoo-4da8a95f7e3613f37d8fd3b764cc93e7ef2531a1.tar.bz2
gentoo-4da8a95f7e3613f37d8fd3b764cc93e7ef2531a1.zip
dev-util/geany-plugins: version bump to 1.31.
New plugin keyrecord with USE flag. Package-Manager: Portage-2.3.6, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/5141
Diffstat (limited to 'dev-util/geany-plugins')
-rw-r--r--dev-util/geany-plugins/Manifest1
-rw-r--r--dev-util/geany-plugins/geany-plugins-1.31.ebuild146
-rw-r--r--dev-util/geany-plugins/metadata.xml1
3 files changed, 148 insertions, 0 deletions
diff --git a/dev-util/geany-plugins/Manifest b/dev-util/geany-plugins/Manifest
index f86ffa3683e4..6b96c669eafc 100644
--- a/dev-util/geany-plugins/Manifest
+++ b/dev-util/geany-plugins/Manifest
@@ -1,2 +1,3 @@
DIST geany-plugins-1.28.tar.gz 4453038 SHA256 918f644053ea205fdf0f2185ac3b8e21339764e0e761a38583f2dda7de7fdb97 SHA512 027fc5923d405a8246786e48e0d36c5da8f580b9f18510933063cc4c452ee5aaa68af4568ee20d640c1dd2bcb29a9361b8558a81a5a83f46b5d99c9ff639306d WHIRLPOOL a328557ccd899ce56ba2cb12875836ecbf5939492a1e19a61e5e2db15a5b10969e1cbf0eb912d551c75e9fa7c49e65fa8a48f7e2e2ebfd4477b4c88b4e6857ea
DIST geany-plugins-1.30.tar.gz 4469990 SHA256 a49202d1c6b2a82446a79c57854596de1e231481163f680c7654f2cb165bc249 SHA512 11dc44215aaa369831c249ef84b5dd0ee7eecdfbbf4707fc6165d78201e9e755447463c171ac6c8b2bc70df28a97b23762073ab9b31f7c33285d4728089da807 WHIRLPOOL ada9c5cd3f78948384c9add373d8b60aa09c0de931304aae4b41f54aaa35dab3450e946e2b39d84c069521113a55720350170edc03253960854a0b842e31903e
+DIST geany-plugins-1.31.tar.gz 4547472 SHA256 933a4f7f041d676f925d021a5adb8c6876879beae53ac06e4a1c70abcb9e25d6 SHA512 73d48b276c93211c6ebc726b24726e7669184d8951d5d29662cb8144c04a239ef8fb621f91b7798720bbdf319a09e35efcaee1535125697838552bd0b1e47bc7 WHIRLPOOL 2a1f4f2a1c88f9bb132b90324ad603a2dce7786eb6c903ebfed9defa140d2756e1ba18e5dffc8b8bd6096ff18b2def1a25f9b163e3f91ec27920aea98489006f
diff --git a/dev-util/geany-plugins/geany-plugins-1.31.ebuild b/dev-util/geany-plugins/geany-plugins-1.31.ebuild
new file mode 100644
index 000000000000..1241ce470d88
--- /dev/null
+++ b/dev-util/geany-plugins/geany-plugins-1.31.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1 vala
+
+DESCRIPTION="A collection of different plugins for Geany"
+HOMEPAGE="https://plugins.geany.org"
+SRC_URI="https://plugins.geany.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="gtk3 +autoclose +automark +commander ctags debugger +defineformat enchant git gpg gtkspell keyrecord lua multiterm nls +overview python scope soup"
+REQUIRED_USE="
+ gtk3? ( !debugger !multiterm !python !scope )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+GTK_COMMON_DEPEND="
+ gtk3? ( x11-libs/gtk+:3 )
+ !gtk3? ( x11-libs/gtk+:2 )
+"
+COMMON_DEPEND="
+ >=dev-util/geany-1.26[gtk3=]
+ dev-libs/glib:2
+ dev-libs/libxml2:2
+ autoclose? ( ${GTK_COMMON_DEPEND} )
+ commander? ( ${GTK_COMMON_DEPEND} )
+ ctags? ( dev-util/ctags )
+ debugger? ( x11-libs/vte:0 )
+ defineformat? ( ${GTK_COMMON_DEPEND} )
+ enchant? ( app-text/enchant )
+ git? ( dev-libs/libgit2:= )
+ gpg? ( app-crypt/gpgme:1= )
+ gtkspell? (
+ gtk3? ( app-text/gtkspell:3= )
+ !gtk3? ( app-text/gtkspell:2 )
+ )
+ keyrecord? ( ${GTK_COMMON_DEPEND} )
+ lua? ( dev-lang/lua:0= )
+ multiterm? (
+ $(vala_depend)
+ x11-libs/gtk+:2
+ >=x11-libs/vte-0.28:0
+ )
+ python? (
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )
+ scope? ( x11-libs/vte:0 )
+ soup? ( net-libs/libsoup:2.4 )
+"
+RDEPEND="${COMMON_DEPEND}
+ scope? ( sys-devel/gdb )
+"
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # bundled lib buster
+ rm markdown/peg-markdown/markdown_lib.c || die
+ # devhelp plugin bundles devhelp
+
+ default
+
+ use multiterm && vala_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-cppcheck
+ --disable-extra-c-warnings
+ $(use_enable !gtk3 geanydoc)
+ # GeanyGenDoc requires ctpl which isn’t yet in portage
+ --disable-geanygendoc
+ # peg-markdown is bundled, use app-text/discount instead
+ --disable-peg-markdown
+ --enable-addons
+ --enable-codenav
+ --enable-geanyextrasel
+ --enable-geanyinsertnum
+ --enable-geanylatex
+ --enable-geanymacro
+ --enable-geanynumberedbookmarks
+ --enable-geanyprj
+ --enable-geanyvc
+ --enable-lineoperations
+ --enable-lipsum
+ --enable-pairtaghighlighter
+ --enable-pohelper
+ --enable-pretty-printer
+ --enable-projectorganizer
+ --enable-sendmail
+ --enable-shiftcolumn
+ --enable-tableconvert
+ --enable-treebrowser
+ --enable-xmlsnippets
+ $(use_enable autoclose)
+ $(use_enable automark)
+ $(use_enable commander)
+ $(use_enable ctags geanyctags)
+ $(use_enable debugger)
+ $(use_enable defineformat)
+ $(use_enable enchant spellcheck)
+ $(use_enable git gitchangebar)
+ $(use_enable gpg geanypg)
+ $(use_enable gtkspell)
+ $(use_enable keyrecord)
+ $(use_enable multiterm)
+ $(use_enable lua geanylua)
+ $(use_enable nls)
+ $(use_enable overview)
+ $(use_enable python geanypy)
+ $(use_enable scope)
+ # Having updatechecker… when you’re using a package manager?
+ $(use_enable soup updatechecker)
+ $(use_enable soup geniuspaste)
+ # Relies on obsolete and vulnerable webkit-gtk versions
+ --disable-devhelp
+ --disable-markdown
+ --disable-webhelper
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --modules
+
+ # make installs all translations if LINGUAS is empty
+ if [[ -n "${LINGUAS+x}" && -z "$LINGUAS" ]]; then
+ rm -r "${D}/usr/share/locale/" || die
+ fi
+}
diff --git a/dev-util/geany-plugins/metadata.xml b/dev-util/geany-plugins/metadata.xml
index 479d6c17f1c7..d9b36784e15b 100644
--- a/dev-util/geany-plugins/metadata.xml
+++ b/dev-util/geany-plugins/metadata.xml
@@ -20,6 +20,7 @@
<flag name="enchant">Enable spell checking using enchant</flag>
<flag name="gpg">Enable geanypg plugin which integrates GPG using <pkg>app-crypt/gpgme</pkg></flag>
<flag name="gtkspell">Use gtkspell for dictionary support in GeanyVC</flag>
+ <flag name="keyrecord">Enable the keyrecord plugin</flag>
<flag name="multiterm">Enable the multiterm plugin</flag>
<flag name="overview">Enable overview plugin</flag>
<flag name="scope">Enable the scope plugin which is a graphical GDB front-end</flag>