summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-06-27 14:47:42 +0300
committerMart Raudsepp <leio@gentoo.org>2020-06-27 14:48:23 +0300
commitb1911f36edd13bae3bc64c3f912b22b098e7883b (patch)
treeca443b81f99396155df6d57fe05d7762ceb60086 /dev-util/gnome-builder
parentx11-libs/gtksourceview: bump to 4.6.1 (diff)
downloadgentoo-b1911f36edd13bae3bc64c3f912b22b098e7883b.tar.gz
gentoo-b1911f36edd13bae3bc64c3f912b22b098e7883b.tar.bz2
gentoo-b1911f36edd13bae3bc64c3f912b22b098e7883b.zip
dev-util/gnome-builder: bump to 3.36.1
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-util/gnome-builder')
-rw-r--r--dev-util/gnome-builder/Manifest1
-rw-r--r--dev-util/gnome-builder/gnome-builder-3.36.1.ebuild177
2 files changed, 178 insertions, 0 deletions
diff --git a/dev-util/gnome-builder/Manifest b/dev-util/gnome-builder/Manifest
index 9077308df019..f8c4baf69d29 100644
--- a/dev-util/gnome-builder/Manifest
+++ b/dev-util/gnome-builder/Manifest
@@ -2,3 +2,4 @@ DIST gnome-builder-3.34.1-patchset.tar.xz 44680 BLAKE2B 91e91ac8d0fcf6b54d32ce9f
DIST gnome-builder-3.34.1.tar.xz 11974748 BLAKE2B c34a31c50b327d02632ff18d48ad59f925306901e8874e0c7811b9258c56027403de0d9dc1877c696d96037bdfcdcc27f56f59a41d232e47b330382b1dbf67e9 SHA512 886c732f20563818dcf1deb96d4277fe96a9499b999cfbc7a64286e816e9a36bb978932d36a1e764b54c2d36891b7546fa058f51e036b0fa101c0872f4ce51d8
DIST gnome-builder-3.36.0-patchset.tar.xz 136856 BLAKE2B a482f371313af4ef6a0881968846c4543d169b6bd36942ae4b72d493012d73c9705e4a7acc8f7dfc1e8cbcdeb2445b4e225f39c3a9a219e24b90be773c0768c1 SHA512 ebaec56950e0e45ba2851b13d4e1518163a291dca207bba25efe12eaaa3cd69e9bae06d2f4e5b9e9852a4305fc3933764ec9a882843f84ce58bd2246991d16fd
DIST gnome-builder-3.36.0.tar.xz 12015980 BLAKE2B 1724c7b17e58fea08cd22894eb260236419f215c1b68d396359ce40432e8a0c08d0ead2b70e888cbb767f78362d4253395b98821fb1d1ff9a07d5881df88c8e3 SHA512 ccd6ca916ed6ad10b69e5573482e2ea48cf4227d858605825ab56989840ebbf5a6dfafc915a1f8df3a1061b37c80adfbd03fc9d616c67e08a5032069b11aa4a6
+DIST gnome-builder-3.36.1.tar.xz 12026976 BLAKE2B d833665bb71b1549fe789d05dbd89db588ae4cc7187e532f38f3bd9e779bccab644d9f9bfc4c84bd484ac678bcf8594e4aa4edff29ea8c87c5c557fc3e422a4f SHA512 284da6e5a9e766cb6f6122f1134c779cde8406b006728ae1fff3518020ef4b96239aa5037cd2d35cfe4728ea088d61c4eeabc39ea753a16208fdaba7b04e63c2
diff --git a/dev-util/gnome-builder/gnome-builder-3.36.1.ebuild b/dev-util/gnome-builder/gnome-builder-3.36.1.ebuild
new file mode 100644
index 000000000000..b524cba0fea4
--- /dev/null
+++ b/dev-util/gnome-builder/gnome-builder-3.36.1.ebuild
@@ -0,0 +1,177 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISABLE_AUTOFORMATTING=1
+FORCE_PRINT_ELOG=1
+
+inherit gnome.org gnome2-utils llvm meson python-single-r1 readme.gentoo-r1 virtualx xdg
+
+DESCRIPTION="An IDE for writing GNOME-based software"
+HOMEPAGE="https://wiki.gnome.org/Apps/Builder"
+
+# FIXME: Review licenses at some point
+LICENSE="GPL-3+ GPL-2+ LGPL-3+ LGPL-2+ MIT CC-BY-SA-3.0 CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="clang +devhelp doc +git +glade gtk-doc spell sysprof test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# When bumping, pay attention to all the included plugins/*/meson.build (and other) build files and the requirements within.
+# `grep -rI dependency * --include='meson.build'` can give a good initial idea for external deps and their double checking.
+# The listed RDEPEND order shold roughly match that output as well, with toplevel one first then sorted by file path.
+# Most plugins have no extra requirements and default to enabled; we need to handle the ones with extra requirements. Many of
+# them have optional runtime dependencies, for which we try to at least notify the user via DOC_CONTENTS (but not all small
+# things); `grep -rI -e 'command-pattern.*=' -e 'push_arg'` can give a (spammy) idea, plus python imports in try/except.
+
+# FIXME: plugin_flatpak needs flatpak.pc >=0.8.0, ostree-1, libsoup-2.4.pc >=2.52.0 and git plugin enabled
+# Editorconfig needs old pcre, with vte migrating away, might want it optional or ported to pcre2?
+# An introspection USE flag of a dep is required if any introspection based language plugin wants to use it (grep for gi.repository). Last full check at 3.28.4
+
+# TODO: Handle llvm slots via llvm.eclass; see plugins/clang/meson.build
+RDEPEND="
+ >=dev-libs/libdazzle-3.33.90[introspection]
+ >=dev-libs/glib-2.61.2:2
+ >=x11-libs/gtk+-3.22.26:3[introspection]
+ >=x11-libs/gtksourceview-4.0.0:4[introspection]
+ >=dev-libs/json-glib-1.2.0
+ >=dev-libs/jsonrpc-glib-3.19.91
+ >=x11-libs/pango-1.38.0
+ >=dev-libs/libpeas-1.22.0[python,${PYTHON_SINGLE_USEDEP}]
+ >=dev-libs/template-glib-3.28.0[introspection]
+ >=x11-libs/vte-0.40.2:2.91[introspection]
+ >=net-libs/webkit-gtk-2.12.0:4=[introspection]
+ >=dev-libs/libxml2-2.9.0
+ git? ( dev-libs/libgit2[ssh,threads]
+ >=dev-libs/libgit2-glib-0.28.0.1[ssh]
+ )
+ dev-libs/libpcre:3
+ dev-libs/libpcre2
+
+ >=dev-libs/gobject-introspection-1.54.0:=
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.22.0:3[${PYTHON_USEDEP}]
+ ')
+ ${PYTHON_DEPS}
+ clang? ( sys-devel/clang:= )
+ devhelp? ( >=dev-util/devhelp-3.25.1:= )
+ glade? ( >=dev-util/glade-3.22.0:3.10 )
+ spell? ( >=app-text/gspell-1.8:0=
+ app-text/enchant:2 )
+ >=dev-util/sysprof-capture-3.33.1:3
+ sysprof? ( >=dev-util/sysprof-3.33.4:0/3[gtk] )
+"
+DEPEND="${RDEPEND}"
+# TODO: runtime ctags path finding..
+
+# desktop-file-utils required for tests, but we have it in deptree for xdg update-desktop-database anyway, so be explicit and unconditional
+# appstream-glib needed for validation with appstream-util with FEATURES=test
+BDEPEND="
+ doc? ( $(python_gen_cond_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ ') )
+ gtk-doc? ( dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3 )
+ test? (
+ dev-libs/appstream-glib
+ sys-apps/dbus )
+ dev-util/desktop-file-utils
+ dev-util/glib-utils
+ >=dev-util/meson-0.49.2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS='gnome-builder can use various other dependencies on runtime to provide
+extra capabilities beyond these expressed via USE flags. Some of these
+that are currently available with packages include:
+
+* dev-util/uncrustify and dev-python/autopep8 for various Code Beautifier
+ plugin out of the box functionality.
+* dev-util/ctags with exuberant-ctags selected via "eselect ctags" for
+ C, C++, Python, JavaScript, CSS, HTML and Ruby autocompletion, semantic
+ highlighting and symbol resolving support.
+* dev-python/jedi and dev-python/lxml for more accurate Python
+ autocompletion support.
+* dev-util/valgrind for integration with valgrind.
+* dev-util/meson for integration with the Meson build system.
+* dev-util/cargo for integration with the Rust Cargo build system.
+* dev-util/cmake for integration with the CMake build system.
+* net-libs/nodejs[npm] for integration with the NPM package system.
+'
+# FIXME: Package gnome-code-assistance and mention here, or maybe USE flag and default enable because it's rather important
+# eslint for additional diagnostics in JavaScript files (what package has this? At least something via NPM..)
+# jhbuild support
+# rust language server via rls; Go via go-langserver
+# autotools stuff for autotools plugin; gtkmm/autoconf-archive for C++ template
+# gjs/gettext/mono/PHPize stuff, but most of these are probably installed for other reasons anyways, when needed inside IDE
+# stylelint for stylesheet (CSS and co) linting
+# gvls for vala language-server integration
+
+llvm_check_deps() {
+ has_version "sys-devel/clang:${LLVM_SLOT}"
+}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ use clang && llvm_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dtracing=false
+ -Dprofiling=false # not passing -pg to CFLAGS
+ -Dtcmalloc=false
+ -Dchannel=other
+
+ $(meson_use doc help)
+ $(meson_use gtk-doc docs)
+
+ -Dnetwork_tests=false
+ $(meson_use clang plugin_clang)
+ $(meson_use devhelp plugin_devhelp)
+ -Dplugin_deviced=false
+ -Dplugin_editorconfig=true # needs libpcre
+ -Dplugin_flatpak=false
+ $(meson_use git plugin_git)
+ $(meson_use glade plugin_glade)
+ -Dplugin_podman=false
+ $(meson_use spell plugin_spellcheck)
+ $(meson_use sysprof plugin_sysprof)
+ -Dplugin_update_manager=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ python_optimize
+ if use doc; then
+ rm "${ED}"/usr/share/doc/gnome-builder/en/.buildinfo || die
+ rm "${ED}"/usr/share/doc/gnome-builder/en/objects.inv || die
+ rm -r "${ED}"/usr/share/doc/gnome-builder/en/.doctrees || die
+ # custom docdir in build system, blocked by https://github.com/mesonbuild/meson/issues/825
+ mv "${ED}"/usr/share/doc/gnome-builder/en "${ED}"/usr/share/doc/${PF}/html || die
+ # _sources subdir left in on purpose, as HTML links to the rst files as "View page source". Additionally default docompress exclusion of /html/ already ensures they aren't compressed, thus linkable as-is.
+ rmdir "${ED}"/usr/share/doc/gnome-builder/ || die
+ fi
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
+
+src_test() {
+ # FIXME: can't run meson_src_test together with virtx or dbus-run-session
+ virtx dbus-run-session meson test -C "${BUILD_DIR}"
+}