summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-03-30 18:26:35 +0200
committerMart Raudsepp <leio@gentoo.org>2019-03-30 18:29:21 +0200
commitbef6e190cd44fcf59e30720d54781301890f643a (patch)
tree1e31d51ae7b86f9e0682e2567d08d4b74660e59b /dev-util/gnome-builder
parentdev-cpp/glibmm: amd64 stable wrt bug #677430 (diff)
downloadgentoo-bef6e190cd44fcf59e30720d54781301890f643a.tar.gz
gentoo-bef6e190cd44fcf59e30720d54781301890f643a.tar.bz2
gentoo-bef6e190cd44fcf59e30720d54781301890f643a.zip
dev-util/gnome-builder-3.24: json-glib[introspection] is required for build
In 3.24 jsonrpc-glib is not a split out separate package, thus the global introspection enabling on gnome-builder affects it as well (not optional). jsonrpc-glib GIR requires json-glib GIR, thus add the missing introspection USE dep on json-glib to ensure successful builds. This is not a problem 3.26 and onwards, as jsonrpc-glib introspection support is controlled by USE flag and there are proper conditional USE deps in place in the external package on json-glib already there. Fixes: https://bugs.gentoo.org/682060 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-util/gnome-builder')
-rw-r--r--dev-util/gnome-builder/gnome-builder-3.24.2-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-util/gnome-builder/gnome-builder-3.24.2-r1.ebuild b/dev-util/gnome-builder/gnome-builder-3.24.2-r1.ebuild
index 296e94b8767..b73fb3fee89 100644
--- a/dev-util/gnome-builder/gnome-builder-3.24.2-r1.ebuild
+++ b/dev-util/gnome-builder/gnome-builder-3.24.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -41,7 +41,7 @@ RDEPEND="
>=dev-libs/libxml2-2.9.0
>=x11-libs/pango-1.38.0
>=dev-libs/libpeas-1.18.0[python,${PYTHON_USEDEP}]
- >=dev-libs/json-glib-1.2.0
+ >=dev-libs/json-glib-1.2.0[introspection]
>=app-text/gspell-1.2.0
>=app-text/enchant-1.6.0
webkit? ( >=net-libs/webkit-gtk-2.12.0:4=[introspection] )