summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/gtk-doc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/gtk-doc')
-rw-r--r--dev-util/gtk-doc/Manifest2
-rw-r--r--dev-util/gtk-doc/files/61gtk-doc-gentoo.el9
-rw-r--r--dev-util/gtk-doc/files/gtk-doc-1.8-emacs-keybindings.patch17
-rw-r--r--dev-util/gtk-doc/gtk-doc-1.21.ebuild120
-rw-r--r--dev-util/gtk-doc/gtk-doc-1.24.ebuild118
-rw-r--r--dev-util/gtk-doc/metadata.xml16
6 files changed, 282 insertions, 0 deletions
diff --git a/dev-util/gtk-doc/Manifest b/dev-util/gtk-doc/Manifest
new file mode 100644
index 000000000000..9bb6d3238c39
--- /dev/null
+++ b/dev-util/gtk-doc/Manifest
@@ -0,0 +1,2 @@
+DIST gtk-doc-1.21.tar.xz 647484 SHA256 5d934d012ee08edd1585544792efa80da271652587ba5b843d2cea8e8b80ee3e SHA512 caef8f6fd42f2961b6703af6d8b9f003b6e6ba2e9e955b94d9c0ecce8d267b7f4c2315d273dbdca1aff244e81867e675434b09a9410248e93101e86105f60f9d WHIRLPOOL cd72184e6f58745573d8bec785b0a8c61f3f68ff9c20254dd6a03e113aeac1672a8408f03c84918c523e2031a98fd5d75990d9377ea8444c2ce7fdba03dfaccc
+DIST gtk-doc-1.24.tar.xz 669664 SHA256 b420759ea05c760301bada14e428f1b321f5312f44e10a176d6804822dabb58b SHA512 a0095efed339cb101dcd947fdc1789edd4a59d7005f6328c68973133795e34819fffdccb4591725b78f8409be95158604387deb681e78ebce0356503de1377a4 WHIRLPOOL b0af2db253147dbf58738e5e66964e6b2000cd3d30f3ef138c81d544a6c12ba2a3b32f71acf3b7677c8562fe945b1d63fe212b99b4f4bb53ccd256bcacb9ad71
diff --git a/dev-util/gtk-doc/files/61gtk-doc-gentoo.el b/dev-util/gtk-doc/files/61gtk-doc-gentoo.el
new file mode 100644
index 000000000000..488a57c02555
--- /dev/null
+++ b/dev-util/gtk-doc/files/61gtk-doc-gentoo.el
@@ -0,0 +1,9 @@
+
+;;; gtk-doc site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'gtk-doc-insert "gtk-doc"
+ "Add a documentation header to the current function." t)
+(autoload 'gtk-doc-insert-section "gtk-doc"
+ "Add a section documentation header at the current position." t)
diff --git a/dev-util/gtk-doc/files/gtk-doc-1.8-emacs-keybindings.patch b/dev-util/gtk-doc/files/gtk-doc-1.8-emacs-keybindings.patch
new file mode 100644
index 000000000000..bbc989afb2b7
--- /dev/null
+++ b/dev-util/gtk-doc/files/gtk-doc-1.8-emacs-keybindings.patch
@@ -0,0 +1,17 @@
+--- gtk-doc-1.8-orig/tools/gtk-doc.el 2007-01-03 16:04:14.000000000 +0100
++++ gtk-doc-1.8/tools/gtk-doc.el 2007-07-29 21:56:45.000000000 +0200
+@@ -262,7 +262,7 @@
+
+ ;; set global binding for this key (follows the format for
+ ;; creating a changelog entry ...)
+-(global-set-key "\C-x4h" 'gtk-doc-insert)
++;;(global-set-key "\C-x4h" 'gtk-doc-insert)
+
+
+ ;; Define another function for inserting a section header.
+@@ -280,4 +280,4 @@
+ " */\n"))
+
+ ;; Set the key binding.
+-(global-set-key "\C-x4s" 'gtk-doc-insert-section)
++;;(global-set-key "\C-x4s" 'gtk-doc-insert-section)
diff --git a/dev-util/gtk-doc/gtk-doc-1.21.ebuild b/dev-util/gtk-doc/gtk-doc-1.21.ebuild
new file mode 100644
index 000000000000..7fdf72261791
--- /dev/null
+++ b/dev-util/gtk-doc/gtk-doc-1.21.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils elisp-common gnome2 python-single-r1 readme.gentoo
+
+DESCRIPTION="GTK+ Documentation Generator"
+HOMEPAGE="http://www.gtk.org/gtk-doc/"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+
+IUSE="doc emacs highlight vim test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# dev-tex/tex4ht blocker needed due bug #315287
+RDEPEND="
+ >=dev-libs/glib-2.6:2
+ >=dev-lang/perl-5.6
+ >=app-text/openjade-1.3.1
+ dev-libs/libxslt
+ >=dev-libs/libxml2-2.3.6:2
+ ~app-text/docbook-xml-dtd-4.3
+ app-text/docbook-xsl-stylesheets
+ ~app-text/docbook-sgml-dtd-3.0
+ >=app-text/docbook-dsssl-stylesheets-1.40
+ emacs? ( virtual/emacs )
+ highlight? (
+ vim? ( || ( app-editors/vim app-editors/gvim ) )
+ !vim? ( dev-util/source-highlight )
+ )
+ !!<dev-tex/tex4ht-20090611_p1038-r1
+"
+DEPEND="${RDEPEND}
+ ~dev-util/gtk-doc-am-${PV}
+ app-text/yelp-tools
+ >=app-text/scrollkeeper-0.3.14
+ virtual/pkgconfig
+ test? ( app-text/scrollkeeper-dtd )
+"
+
+pkg_setup() {
+ DOC_CONTENTS="gtk-doc does no longer define global key bindings for Emacs.
+ You may set your own key bindings for \"gtk-doc-insert\" and
+ \"gtk-doc-insert-section\" in your ~/.emacs file."
+ SITEFILE=61${PN}-gentoo.el
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Always disable fop; it is unreliable enough that gtk-doc upstream
+ # commented it out by default, and if it's autodetected, it causes build
+ # failures in other packages, bug #403165
+ sed -e 's:test -n "@FOP@":test -n "":' \
+ -i gtkdoc-mkpdf.in || die "sed failed"
+
+ # Remove global Emacs keybindings, bug #184588
+ epatch "${FILESDIR}/${PN}-1.8-emacs-keybindings.patch"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ if use vim; then
+ myconf="${myconf} $(use_with highlight highlight vim)"
+ else
+ G2CONF="${myconf} $(use_with highlight highlight source-highlight)"
+ fi
+
+ gnome2_src_configure \
+ --with-xml-catalog="${EPREFIX}/etc/xml/catalog" \
+ ${myconf}
+}
+
+src_compile() {
+ gnome2_src_compile
+ use emacs && elisp-compile tools/gtk-doc.el
+}
+
+src_install() {
+ gnome2_src_install
+
+ python_fix_shebang "${ED}"/usr/bin/gtkdoc-depscan
+
+ # Don't install those files, they are in gtk-doc-am now
+ rm "${ED}"/usr/share/aclocal/gtk-doc.m4 || die "failed to remove gtk-doc.m4"
+ rm "${ED}"/usr/bin/gtkdoc-rebase || die "failed to remove gtkdoc-rebase"
+
+ if use doc; then
+ docinto doc
+ dodoc doc/*
+ docinto examples
+ dodoc examples/*
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} tools/gtk-doc.el*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ readme.gentoo_create_doc
+ fi
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if use emacs; then
+ elisp-site-regen
+ readme.gentoo_print_elog
+ fi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/gtk-doc/gtk-doc-1.24.ebuild b/dev-util/gtk-doc/gtk-doc-1.24.ebuild
new file mode 100644
index 000000000000..46298862228e
--- /dev/null
+++ b/dev-util/gtk-doc/gtk-doc-1.24.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils elisp-common gnome2 python-single-r1 readme.gentoo
+
+DESCRIPTION="GTK+ Documentation Generator"
+HOMEPAGE="http://www.gtk.org/gtk-doc/"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+
+IUSE="doc emacs highlight vim"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# dev-tex/tex4ht blocker needed due bug #315287
+RDEPEND="
+ >=dev-libs/glib-2.6:2
+ >=dev-lang/perl-5.6
+ >=app-text/openjade-1.3.1
+ dev-libs/libxslt
+ >=dev-libs/libxml2-2.3.6:2
+ ~app-text/docbook-xml-dtd-4.3
+ app-text/docbook-xsl-stylesheets
+ ~app-text/docbook-sgml-dtd-3.0
+ >=app-text/docbook-dsssl-stylesheets-1.40
+ emacs? ( virtual/emacs )
+ highlight? (
+ vim? ( || ( app-editors/vim app-editors/gvim ) )
+ !vim? ( dev-util/source-highlight )
+ )
+ !!<dev-tex/tex4ht-20090611_p1038-r1
+"
+DEPEND="${RDEPEND}
+ ~dev-util/gtk-doc-am-${PV}
+ app-text/yelp-tools
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ DOC_CONTENTS="gtk-doc does no longer define global key bindings for Emacs.
+ You may set your own key bindings for \"gtk-doc-insert\" and
+ \"gtk-doc-insert-section\" in your ~/.emacs file."
+ SITEFILE=61${PN}-gentoo.el
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Always disable fop; it is unreliable enough that gtk-doc upstream
+ # commented it out by default, and if it's autodetected, it causes build
+ # failures in other packages, bug #403165
+ sed -e 's:test -n "@FOP@":test -n "":' \
+ -i gtkdoc-mkpdf.in || die "sed failed"
+
+ # Remove global Emacs keybindings, bug #184588
+ epatch "${FILESDIR}"/${PN}-1.8-emacs-keybindings.patch
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ if use vim; then
+ myconf="${myconf} $(use_with highlight highlight vim)"
+ else
+ myconf="${myconf} $(use_with highlight highlight source-highlight)"
+ fi
+
+ gnome2_src_configure \
+ --with-xml-catalog="${EPREFIX}"/etc/xml/catalog \
+ ${myconf}
+}
+
+src_compile() {
+ gnome2_src_compile
+ use emacs && elisp-compile tools/gtk-doc.el
+}
+
+src_install() {
+ gnome2_src_install
+
+ python_fix_shebang "${ED}"/usr/bin/gtkdoc-depscan
+
+ # Don't install those files, they are in gtk-doc-am now
+ rm "${ED}"/usr/share/aclocal/gtk-doc.m4 || die "failed to remove gtk-doc.m4"
+ rm "${ED}"/usr/bin/gtkdoc-rebase || die "failed to remove gtkdoc-rebase"
+
+ if use doc; then
+ docinto doc
+ dodoc doc/*
+ docinto examples
+ dodoc examples/*
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} tools/gtk-doc.el*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ readme.gentoo_create_doc
+ fi
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if use emacs; then
+ elisp-site-regen
+ readme.gentoo_print_elog
+ fi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/gtk-doc/metadata.xml b/dev-util/gtk-doc/metadata.xml
new file mode 100644
index 000000000000..a562fd84b87c
--- /dev/null
+++ b/dev-util/gtk-doc/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<use>
+ <flag name="highlight">Enable source code highlighting</flag>
+ <flag name="vim">Enable source code highlighting through
+ <pkg>app-editors/vim</pkg></flag>
+</use>
+<longdescription lang="en">
+ GTK-Doc is used to document C code.
+ It is typically used to document the public API of libraries,
+ such as the GTK+ and GNOME libraries, but it can also be used
+ to document application code.
+</longdescription>
+</pkgmetadata>