summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/hxd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/hxd')
-rw-r--r--dev-util/hxd/Manifest1
-rw-r--r--dev-util/hxd/files/hxd-0.70.02-llong-redef.patch25
-rw-r--r--dev-util/hxd/files/hxd-0.70.02-prll-flags.patch56
-rw-r--r--dev-util/hxd/hxd-0.70.02-r1.ebuild29
-rw-r--r--dev-util/hxd/metadata.xml7
5 files changed, 118 insertions, 0 deletions
diff --git a/dev-util/hxd/Manifest b/dev-util/hxd/Manifest
new file mode 100644
index 000000000000..adce36401961
--- /dev/null
+++ b/dev-util/hxd/Manifest
@@ -0,0 +1 @@
+DIST hxd-0.70.02.tar.gz 17469 SHA256 2b533e2585bee6c08e7761b6ed67c5ecb01742d2aa3510c45931472512ad2311 SHA512 631b3ea74a7f831984abb1bb0c1a32d38ff2980063321fa1e85fc594fe23407cddf5d61fd1005ec154aecf6be8344e070600faf90d176061f195e6a39d8991af WHIRLPOOL 8b1c8a4e1ecdcb21828fa76f971455bbb8913ce6a24701fc17849e5373c9c9c75f735c2a85a3d686d33b3b35958edce1ed577627441dc83ae92b5430e08286fd
diff --git a/dev-util/hxd/files/hxd-0.70.02-llong-redef.patch b/dev-util/hxd/files/hxd-0.70.02-llong-redef.patch
new file mode 100644
index 000000000000..e9e230c867ac
--- /dev/null
+++ b/dev-util/hxd/files/hxd-0.70.02-llong-redef.patch
@@ -0,0 +1,25 @@
+ general.h | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/general.h b/general.h
+index 0a2ebe7..b749945 100644
+--- a/general.h
++++ b/general.h
+@@ -56,7 +56,7 @@
+
+ #ifdef HAVE_LONGLONG
+ loff_t lseek64( int fd, loff_t offset, int whence );
+-#define LLONG_MAX 0x7fffffffffffffffll
++#define L_LONG_MAX 0x7fffffffffffffffll
+ #undef LSEEK
+ #define LSEEK(A,B,C) lseek64((A),(B),(C))
+ #undef STRTOL
+@@ -64,7 +64,7 @@ loff_t lseek64( int fd, loff_t offset, int whence );
+ #undef SIZE_MIN
+ #define SIZE_MIN ( (loff_t) 0 )
+ #undef SIZE_MAX
+-#define SIZE_MAX ( LLONG_MAX - 1 )
++#define SIZE_MAX ( L_LONG_MAX - 1 )
+ #undef OFF_T
+ #define OFF_T loff_t
+ #endif
diff --git a/dev-util/hxd/files/hxd-0.70.02-prll-flags.patch b/dev-util/hxd/files/hxd-0.70.02-prll-flags.patch
new file mode 100644
index 000000000000..f08f2eb18063
--- /dev/null
+++ b/dev-util/hxd/files/hxd-0.70.02-prll-flags.patch
@@ -0,0 +1,56 @@
+ Makefile.Linux | 23 +++++++++++++++--------
+ 1 files changed, 15 insertions(+), 8 deletions(-)
+
+diff --git a/Makefile.Linux b/Makefile.Linux
+index e3711cd..d5b00cb 100644
+--- a/Makefile.Linux
++++ b/Makefile.Linux
+@@ -1,6 +1,6 @@
+-CC=gcc
+-CFLAGS=-Wall -Wstrict-prototypes -fomit-frame-pointer -pipe -I$(HDDIR) -DOS_TYPE_Linux -DOS_TYPE_STR=\"Linux\"
+-LDFLAGS=-Wl,-warn-common -s -L$(LIBDIR)
++CC ?=gcc
++CFLAGS+=-Wall -Wstrict-prototypes -I$(HDDIR) -DOS_TYPE_Linux -DOS_TYPE_STR=\"Linux\"
++LDFLAGS+=-Wl,-warn-common -L$(LIBDIR)
+
+ LDLIBS =
+ HDDIR = ./
+@@ -32,26 +32,33 @@ $(PRG_UNDUMP): $(PRG_UNDUMP).c $(PRG_UNDUMP).h general.h
+ $(CC) $(CFLAGS) -Dprg_name=\"$(PRG_UNDUMP)\" -DMANUAL_NUMBER=$(MAN_NO_UNDUMP) $(LDFLAGS) $(PRG_UNDUMP).c -o $@
+
+
+-$(MAN_DUMP): $(PRG_DUMP).man
++mkmkman: $(PRG_DUMP)
+ $(CC) $(CFLAGS) -Dprg_name=\"$(PRG_DUMP)\" -DMANUAL_NUMBER=$(MAN_NO_DUMP) -Dundump_name=\"$(PRG_UNDUMP)\" $(LDFLAGS) mkmkman.c -o mkmkman
++
++mkman.c: mkmkman $(PRG_DUMP).man
+ cat $(PRG_DUMP).man | ./mkmkman > mkman.c
+ ln -sf $(PRG_DUMP).h header.h
++
++$(MAN_DUMP): mkman.c
+ $(CC) $(CFLAGS) -Dprg_name=\"$(PRG_DUMP)\" -DMANUAL_NUMBER=$(MAN_NO_DUMP) -Dundump_name=\"$(PRG_UNDUMP)\" $(LDFLAGS) mkman.c -o mkman
+ ./mkman > $@
+
+-
+-$(MAN_UNDUMP): $(PRG_UNDUMP).man
++mkmkman_u: $(MAN_DUMP) $(PRG_UNDUMP)
+ $(CC) $(CFLAGS) -Dprg_name=\"$(PRG_UNDUMP)\" -DMANUAL_NUMBER=$(MAN_NO_UNDUMP) -Ddump_name=\"$(PRG_DUMP)\" $(LDFLAGS) mkmkman.c -o mkmkman
++
++mkman_u.c: $(PRG_UNDUMP).man mkmkman_u
+ cat $(PRG_UNDUMP).man | ./mkmkman > mkman.c
+ ln -sf $(PRG_UNDUMP).h header.h
++
++$(MAN_UNDUMP): $(MAN_UNDUMP) mkman_u.c
+ $(CC) $(CFLAGS) -Dprg_name=\"$(PRG_UNDUMP)\" -DMANUAL_NUMBER=$(MAN_NO_UNDUMP) -Ddump_name=\"$(PRG_DUMP)\" $(LDFLAGS) mkman.c -o mkman
+ ./mkman > $@
+
+
+ install: all
+- install -s -m 0755 -o root -g root $(PRG_DUMP) $(INSTALLDIR_BIN_DUMP)
++ install -m 0755 -o root -g root $(PRG_DUMP) $(INSTALLDIR_BIN_DUMP)
+ install -m 0644 -o root -g root $(MAN_DUMP) $(INSTALLDIR_MAN_DUMP)
+- install -s -m 0755 -o root -g root $(PRG_UNDUMP) $(INSTALLDIR_BIN_UNDUMP)
++ install -m 0755 -o root -g root $(PRG_UNDUMP) $(INSTALLDIR_BIN_UNDUMP)
+ install -m 0644 -o root -g root $(MAN_UNDUMP) $(INSTALLDIR_MAN_UNDUMP)
+
+ clean:
diff --git a/dev-util/hxd/hxd-0.70.02-r1.ebuild b/dev-util/hxd/hxd-0.70.02-r1.ebuild
new file mode 100644
index 000000000000..8e23f0b3e44e
--- /dev/null
+++ b/dev-util/hxd/hxd-0.70.02-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Binary to hexadecimal converter"
+HOMEPAGE="http://www-tet.ee.tu-berlin.de/solyga/linux/"
+SRC_URI="http://linux.xulin.de/c/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~sparc ~mips ~ppc"
+IUSE=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-prll-flags.patch \
+ "${FILESDIR}"/${P}-llong-redef.patch
+ tc-export CC
+}
+
+src_install() {
+ dobin hxd unhxd
+ doman hxd.1 unhxd.1
+ dodoc README TODO
+}
diff --git a/dev-util/hxd/metadata.xml b/dev-util/hxd/metadata.xml
new file mode 100644
index 000000000000..91f4e72fb544
--- /dev/null
+++ b/dev-util/hxd/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>