summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-25 18:49:41 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-25 18:50:46 +0100
commitb231567a6b32efa37659a04e70119018d1253f94 (patch)
tree13cc661cfdf0fb4e5e4499497a4c303e471fa191 /dev-util/kdevelop-python/kdevelop-python-5.4.4.ebuild
parentdev-util/kdevelop-php: Drop 5.4.4 (diff)
downloadgentoo-b231567a6b32efa37659a04e70119018d1253f94.tar.gz
gentoo-b231567a6b32efa37659a04e70119018d1253f94.tar.bz2
gentoo-b231567a6b32efa37659a04e70119018d1253f94.zip
dev-util/kdevelop-python: Drop 5.4.4
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util/kdevelop-python/kdevelop-python-5.4.4.ebuild')
-rw-r--r--dev-util/kdevelop-python/kdevelop-python-5.4.4.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-util/kdevelop-python/kdevelop-python-5.4.4.ebuild b/dev-util/kdevelop-python/kdevelop-python-5.4.4.ebuild
deleted file mode 100644
index 8eef9e15c30..00000000000
--- a/dev-util/kdevelop-python/kdevelop-python-5.4.4.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ECM_TEST="forceoptional"
-KDE_ORG_NAME="kdev-python"
-PYTHON_COMPAT=( python3_{6,7} )
-KFMIN=5.60.0
-QTMIN=5.12.3
-inherit ecm kde.org python-single-r1
-
-if [[ ${KDE_BUILD_TYPE} = release ]]; then
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Python plugin for KDevelop"
-HOMEPAGE="https://www.kdevelop.org/"
-
-LICENSE="GPL-2" # TODO: CHECK
-SLOT="5"
-IUSE=""
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
- >=kde-frameworks/kcompletion-${KFMIN}:5
- >=kde-frameworks/kconfig-${KFMIN}:5
- >=kde-frameworks/kcoreaddons-${KFMIN}:5
- >=kde-frameworks/ki18n-${KFMIN}:5
- >=kde-frameworks/kio-${KFMIN}:5
- >=kde-frameworks/kitemmodels-${KFMIN}:5
- >=kde-frameworks/knewstuff-${KFMIN}:5
- >=kde-frameworks/kparts-${KFMIN}:5
- >=kde-frameworks/ktexteditor-${KFMIN}:5
- >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
- >=kde-frameworks/kxmlgui-${KFMIN}:5
- >=kde-frameworks/threadweaver-${KFMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- dev-util/kdevelop:5=
-"
-RDEPEND="${DEPEND}
- dev-python/pycodestyle[${PYTHON_USEDEP}]
-"
-
-RESTRICT+=" test"
-
-pkg_setup() {
- python-single-r1_pkg_setup
- ecm_pkg_setup
-}