summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-06-22 23:57:51 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-06-22 23:57:51 +0200
commit03e328116a02937579c4182a5ab249a54bcc0a7f (patch)
treeb444fab5967859beb34b6b7e33a9e33897366012 /dev-util/lockrun/lockrun-20120508-r1.ebuild
parentdev-util/huc: punt DOCS array. (diff)
downloadgentoo-03e328116a02937579c4182a5ab249a54bcc0a7f.tar.gz
gentoo-03e328116a02937579c4182a5ab249a54bcc0a7f.tar.bz2
gentoo-03e328116a02937579c4182a5ab249a54bcc0a7f.zip
dev-util/lockrun: EAPI 6 bump.
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'dev-util/lockrun/lockrun-20120508-r1.ebuild')
-rw-r--r--dev-util/lockrun/lockrun-20120508-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/lockrun/lockrun-20120508-r1.ebuild b/dev-util/lockrun/lockrun-20120508-r1.ebuild
new file mode 100644
index 000000000000..1a0c8c9f4992
--- /dev/null
+++ b/dev-util/lockrun/lockrun-20120508-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lockrun - runs cronjobs with overrun protection"
+HOMEPAGE="http://www.unixwiz.net/tools/lockrun.html"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp -v "${FILESDIR}"/${PN}.c-${PV} "${S}"/${PN}.c || die
+ cp -v "${FILESDIR}"/${PN}.c-${PV} "${S}"/README || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) ${PN}
+ sed -i README -e '60q;s|^ \*||g' || die
+}
+
+src_install () {
+ dobin ${PN}
+ einstalldocs
+}