summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-11-09 21:03:16 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-11-09 21:03:25 +0000
commita35e6bc22c84fdc91e392ca942a743025af67788 (patch)
treef1a3a2b663ce854138eea96e89d8eff2943c49a9 /dev-util/ltrace
parentdev-tex/newlfm: bump EAPI and stuff (diff)
downloadgentoo-a35e6bc22c84fdc91e392ca942a743025af67788.tar.gz
gentoo-a35e6bc22c84fdc91e392ca942a743025af67788.tar.bz2
gentoo-a35e6bc22c84fdc91e392ca942a743025af67788.zip
dev-util/ltrace: add RESTRICT="!test? ( test )", bump to EAPI=7
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util/ltrace')
-rw-r--r--dev-util/ltrace/files/ltrace-0.7.3-alpha-protos.patch10
-rw-r--r--dev-util/ltrace/ltrace-0.7.3_p4.ebuild24
2 files changed, 20 insertions, 14 deletions
diff --git a/dev-util/ltrace/files/ltrace-0.7.3-alpha-protos.patch b/dev-util/ltrace/files/ltrace-0.7.3-alpha-protos.patch
index 659952bdf148..7ff573272963 100644
--- a/dev-util/ltrace/files/ltrace-0.7.3-alpha-protos.patch
+++ b/dev-util/ltrace/files/ltrace-0.7.3-alpha-protos.patch
@@ -2,13 +2,11 @@ Fix build failure on alpha:
plt.c:32:12: error: dereferencing pointer to incomplete type ‘struct library_symbol’
return sym->enter_addr;
^
-diff -U0 -raN ltrace-0.7.3/sysdeps/linux-gnu/alpha/plt.c ltrace-0.7.3/sysdeps/linux-gnu/alpha/plt.c
---- ltrace-0.7.3_p4/work/ltrace-0.7.3/sysdeps/linux-gnu/alpha/plt.c 2012-11-10 13:43:55.000000000 +0100
-+++ foo/work/ltrace-0.7.3/sysdeps/linux-gnu/alpha/plt.c 2016-06-27 23:21:28.000000000 +0200
+--- a/sysdeps/linux-gnu/alpha/plt.c 2012-11-10 13:43:55.000000000 +0100
++++ b/sysdeps/linux-gnu/alpha/plt.c 2016-06-27 23:21:28.000000000 +0200
@@ -23,0 +24 @@
+#include "library.h"
-diff -U0 -raN ltrace-0.7.3/sysdeps/linux-gnu/alpha/trace.c ltrace-0.7.3/sysdeps/linux-gnu/alpha/trace.c
---- ltrace-0.7.3_p4/work/ltrace-0.7.3/sysdeps/linux-gnu/alpha/trace.c 2016-06-27 23:30:08.000000000 +0200
-+++ foo/work/ltrace-0.7.3/sysdeps/linux-gnu/alpha/trace.c 2016-06-27 23:25:20.000000000 +0200
+--- a/sysdeps/linux-gnu/alpha/trace.c 2016-06-27 23:30:08.000000000 +0200
++++ b/sysdeps/linux-gnu/alpha/trace.c 2016-06-27 23:25:20.000000000 +0200
@@ -29,0 +30 @@
+#include "backend.h"
diff --git a/dev-util/ltrace/ltrace-0.7.3_p4.ebuild b/dev-util/ltrace/ltrace-0.7.3_p4.ebuild
index abe4ea0c259e..2f15597a0646 100644
--- a/dev-util/ltrace/ltrace-0.7.3_p4.ebuild
+++ b/dev-util/ltrace/ltrace-0.7.3_p4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit autotools eutils
+EAPI=7
+inherit autotools
LTRACE_V=${PV/_p*/}
DB_V=${PV/*_p/}
@@ -26,15 +26,23 @@ DEPEND="${RDEPEND}
sys-libs/binutils-libs
test? ( dev-util/dejagnu )"
+RESTRICT="!test? ( test )"
+
S=${WORKDIR}/${PN}-${LTRACE_V}
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.3-test-protos.patch #bug 421649
+ "${FILESDIR}"/${PN}-0.7.3-alpha-protos.patch
+ "${FILESDIR}"/${PN}-0.7.3-ia64.patch
+ "${FILESDIR}"/${PN}-0.7.3-print-test-pie.patch
+ "${FILESDIR}"/${PN}-0.7.3-ia64-pid_t.patch
+)
+
src_prepare() {
- epatch "${WORKDIR}"/debian/patches/[0-9]*
- epatch "${FILESDIR}"/${PN}-0.7.3-test-protos.patch #bug 421649
- epatch "${FILESDIR}"/${PN}-0.7.3-alpha-protos.patch
- epatch "${FILESDIR}"/${PN}-0.7.3-ia64.patch
- epatch "${FILESDIR}"/${PN}-0.7.3-print-test-pie.patch
- epatch "${FILESDIR}"/${PN}-0.7.3-ia64-pid_t.patch
+ eapply "${WORKDIR}"/debian/patches/[0-9]*
+
+ default
+
sed -i '/^dist_doc_DATA/d' Makefile.am || die
eautoreconf
}