summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-01-07 18:47:15 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2018-01-07 19:39:45 +0000
commitd4ea3345c8720019a14499df396122fb62b45e77 (patch)
tree97fc9ad57fa799db0a931b2fe670e146f7243a1a /dev-util/mingw-runtime/mingw-runtime-3.18.ebuild
parentdev-util/mingw64-runtime: Migrate CROSSCOMPILE_OPTS=headers-only -> USE=heade... (diff)
downloadgentoo-d4ea3345c8720019a14499df396122fb62b45e77.tar.gz
gentoo-d4ea3345c8720019a14499df396122fb62b45e77.tar.bz2
gentoo-d4ea3345c8720019a14499df396122fb62b45e77.zip
dev-util/mingw-runtime: Migrate CROSSCOMPILE_OPTS=headers-only -> USE=headers-only
CROSSCOMPILE_OPTS is a USE_EXPAND of a single item: headers-only. Convert it to a global USE flag instead. Mechanical ebuild rename done as: $ sed -e 's@crosscompile_opts_headers-only@headers-only@g' \ -i $(git grep -l headers-only) 'headers-only' flag is used by crossdev to bootstrap stage1 compiler before libc is available. crossdev switched to USE=headers-only in =sys-devel/crossdev-20171230. Bug: https://bugs.gentoo.org/642712 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-util/mingw-runtime/mingw-runtime-3.18.ebuild')
-rw-r--r--dev-util/mingw-runtime/mingw-runtime-3.18.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-util/mingw-runtime/mingw-runtime-3.18.ebuild b/dev-util/mingw-runtime/mingw-runtime-3.18.ebuild
index fb7b3aaaadba..9a9542756fcb 100644
--- a/dev-util/mingw-runtime/mingw-runtime-3.18.ebuild
+++ b/dev-util/mingw-runtime/mingw-runtime-3.18.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
export CBUILD=${CBUILD:-${CHOST}}
@@ -19,7 +19,7 @@ SRC_URI="mirror://sourceforge/mingw/${MY_P}-src.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~ppc ~sparc x86"
-IUSE="crosscompile_opts_headers-only"
+IUSE="headers-only"
RESTRICT="strip"
S=${WORKDIR}/${MY_P}
@@ -28,7 +28,7 @@ is_crosscompile() {
[[ ${CHOST} != ${CTARGET} ]]
}
just_headers() {
- use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
+ use headers-only && [[ ${CHOST} != ${CTARGET} ]]
}
pkg_setup() {