summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2016-11-22 01:36:50 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2016-11-22 01:36:50 +0300
commit4ea581785bda37bc01a20fbf5095c087e3bcda26 (patch)
tree5e73e985ac2e3ff0de407213300c30eb7eaf13bb /dev-util/oprofile
parentsys-process/systemd-cron: amd64 stable (diff)
downloadgentoo-4ea581785bda37bc01a20fbf5095c087e3bcda26.tar.gz
gentoo-4ea581785bda37bc01a20fbf5095c087e3bcda26.tar.bz2
gentoo-4ea581785bda37bc01a20fbf5095c087e3bcda26.zip
dev-util/oprofile: fix bug 600000
Remove -ftemplate-depth-50 limitation from configure: this is not sufficient depth with gcc-6.2, see bug 600000 for details. Package-Manager: portage-2.3.2 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'dev-util/oprofile')
-rw-r--r--dev-util/oprofile/files/oprofile-1.1.0-gcc6-template-depth.patch10
-rw-r--r--dev-util/oprofile/oprofile-1.1.0-r1.ebuild5
2 files changed, 14 insertions, 1 deletions
diff --git a/dev-util/oprofile/files/oprofile-1.1.0-gcc6-template-depth.patch b/dev-util/oprofile/files/oprofile-1.1.0-gcc6-template-depth.patch
new file mode 100644
index 000000000000..01fc86910a3a
--- /dev/null
+++ b/dev-util/oprofile/files/oprofile-1.1.0-gcc6-template-depth.patch
@@ -0,0 +1,10 @@
+--- oprofile-1.1.0/configure.ac.orig 2015-07-21 17:53:27.000000000 +0300
++++ oprofile-1.1.0/configure.ac 2016-11-22 01:15:31.329067697 +0300
+@@ -320,7 +320,6 @@
+ AX_CXXFLAGS_OPTION(OP_CXXFLAGS,[-Wall])
+ AX_CFLAGS_OPTION(OP_CFLAGS,[-fno-common])
+ AX_CXXFLAGS_OPTION(OP_CXXFLAGS,[-fno-common])
+-AX_CXXFLAGS_OPTION(OP_CXXFLAGS,[-ftemplate-depth-50])
+ AX_CFLAGS_OPTION(OP_CFLAGS,[-Wdeclaration-after-statement])
+
+ dnl enable option to use GCC test coverage
diff --git a/dev-util/oprofile/oprofile-1.1.0-r1.ebuild b/dev-util/oprofile/oprofile-1.1.0-r1.ebuild
index 6e83c7c0cddf..57474e727c1a 100644
--- a/dev-util/oprofile/oprofile-1.1.0-r1.ebuild
+++ b/dev-util/oprofile/oprofile-1.1.0-r1.ebuild
@@ -3,7 +3,7 @@
# $Id$
EAPI="5"
-inherit eutils java-pkg-opt-2 linux-info multilib user
+inherit autotools eutils java-pkg-opt-2 linux-info multilib user
MY_P=${PN}-${PV/_/-}
DESCRIPTION="A transparent low-overhead system-wide profiler"
@@ -46,6 +46,9 @@ pkg_setup() {
src_prepare() {
# fix bug #594178
epatch "${FILESDIR}/${PN}-1.1.0-gcc6.patch"
+ # bug #600000
+ epatch "${FILESDIR}/${PN}-1.1.0-gcc6-template-depth.patch"
+ eautoreconf
}
src_configure() {