summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-11-27 19:54:16 -0800
committerZac Medico <zmedico@gentoo.org>2018-11-27 19:57:29 -0800
commitcb62b1c319a888c476a51729a706e63cdc43a3f1 (patch)
treef8042152c40558f548c6198ef5b65da566b46419 /dev-util/ostree
parentapp-emulation/buildah: version bump to 1.5 (diff)
downloadgentoo-cb62b1c319a888c476a51729a706e63cdc43a3f1.tar.gz
gentoo-cb62b1c319a888c476a51729a706e63cdc43a3f1.tar.bz2
gentoo-cb62b1c319a888c476a51729a706e63cdc43a3f1.zip
dev-util/ostree: version bump to 2018.9
Closes: https://bugs.gentoo.org/668132 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-util/ostree')
-rw-r--r--dev-util/ostree/Manifest1
-rw-r--r--dev-util/ostree/metadata.xml2
-rw-r--r--dev-util/ostree/ostree-2018.9.ebuild107
3 files changed, 110 insertions, 0 deletions
diff --git a/dev-util/ostree/Manifest b/dev-util/ostree/Manifest
index efb030b2fe29..87e278a57a80 100644
--- a/dev-util/ostree/Manifest
+++ b/dev-util/ostree/Manifest
@@ -1 +1,2 @@
DIST ostree-2018.5.tar.xz 1937184 BLAKE2B ff126d2963296eb9ac270816efed7d2fbfdbcc7b0dba69007ae83e4499a46ef21a5b4e5d387de9bd387af0fe8d4086427d1aa9043c246a49676d116e919a93e6 SHA512 03854c662cddc1e0c7150bb62bbdd2990cf091ef126ddc5bb94494fee2ffb0383afb067b89d63c3e4f39849e2c8b7cabfd887d0d6fc1e7a43fda4fe7da1dc2e8
+DIST ostree-2018.9.tar.xz 1951732 BLAKE2B c6fba1321fe21bff569fe1dadd1aa649f23059a35dc906c3a0b7dcca29f7acbe8338e19541d8f7d854452bf6a6b1ac293d4350c7056a9b13b9ed1eacf358d4b3 SHA512 407b6b67add54e80a55fc35f08bde56561009db93ec202a10dd1ec1e66bd32b439c1d66c759e4e173e44fce6fbc2c162cae928a477c9d7abafbf007ed8f7bfb5
diff --git a/dev-util/ostree/metadata.xml b/dev-util/ostree/metadata.xml
index d31a82267686..4fb7a62d6f22 100644
--- a/dev-util/ostree/metadata.xml
+++ b/dev-util/ostree/metadata.xml
@@ -30,7 +30,9 @@
it's just a more polished version of Linux VServer hardlinks.
</longdescription>
<use>
+ <flag name="archive">Use libarchive</flag>
<flag name="grub">Enable grub configuration generator</flag>
+ <flag name="libmount">Use libmount</flag>
<flag name="soup">Use libsoup for networking</flag>
</use>
<upstream>
diff --git a/dev-util/ostree/ostree-2018.9.ebuild b/dev-util/ostree/ostree-2018.9.ebuild
new file mode 100644
index 000000000000..495e21ac476f
--- /dev/null
+++ b/dev-util/ostree/ostree-2018.9.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Operating system and container binary deployment and upgrades"
+HOMEPAGE="https://ostree.readthedocs.io/en/latest/"
+SRC_URI="https://github.com/ostreedev/${PN}/releases/download/v${PV}/lib${P}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="archive curl doc gnutls grub introspection libmount selinux ssl soup systemd zeroconf"
+RESTRICT="test"
+
+S="${WORKDIR}/lib${P}"
+COMMON_DEPEND="
+ app-arch/xz-utils:=
+ app-crypt/gpgme:=
+ dev-libs/glib:=
+ dev-libs/libassuan:=
+ dev-libs/libgpg-error:=
+ dev-libs/openssl:=
+ sys-apps/util-linux:=
+ sys-fs/fuse:=
+ sys-libs/zlib:=
+
+ archive? ( app-arch/libarchive:= )
+ grub? ( sys-boot/grub:* )
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? ( dev-libs/openssl:= )
+ )
+ libmount? ( sys-apps/util-linux:= )
+ selinux? ( sys-libs/libselinux:= )
+ soup? ( net-libs/libsoup:= )
+ systemd? ( sys-apps/systemd:= )
+ zeroconf? ( net-dns/avahi:* )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ app-text/docbook-xsl-stylesheets
+ sys-devel/bison
+ dev-libs/libxslt
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+ curl? ( net-misc/curl:= )
+ introspection? ( dev-libs/gobject-introspection )
+ doc? ( dev-util/gtk-doc )
+"
+RDEPEND="${COMMON_DEPEND}"
+
+src_prepare() {
+ default
+ sed -Ee 's:(XSLT_STYLESHEET = ).*:\1/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl:' \
+ -i Makefile.in Makefile-man.am || die
+
+ # The ostree-finalize-staged.path file is missing in ostree-2018.9.tar.xz.
+ [[ -e src/boot/ostree-finalize-staged.path ]] && die
+ cat > src/boot/ostree-finalize-staged.path <<-EOF
+ # Copyright (C) 2018 Red Hat, Inc.
+ #
+ # This library is free software; you can redistribute it and/or
+ # modify it under the terms of the GNU Lesser General Public
+ # License as published by the Free Software Foundation; either
+ # version 2 of the License, or (at your option) any later version.
+ #
+ # This library is distributed in the hope that it will be useful,
+ # but WITHOUT ANY WARRANTY; without even the implied warranty of
+ # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ # Lesser General Public License for more details.
+ #
+ # You should have received a copy of the GNU Lesser General Public
+ # License along with this library; if not, write to the
+ # Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+ # Boston, MA 02111-1307, USA.
+
+ # For some implementation discussion, see:
+ # https://lists.freedesktop.org/archives/systemd-devel/2018-March/040557.html
+ [Unit]
+ Description=OSTree Monitor Staged Deployment
+ Documentation=man:ostree(1)
+
+ [Path]
+ PathExists=/run/ostree/staged-deployment
+
+ [Install]
+ WantedBy=multi-user.target
+ EOF
+}
+
+src_configure() {
+ unset ${!XDG_*} #657346 g-ir-scanner sandbox violation
+ econf \
+ --enable-man \
+ $(use_with archive libarchive) \
+ $(use_with curl) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable introspection) \
+ $(use_with selinux ) \
+ $(use_with soup) \
+ $(use_with libmount) \
+ $(use ssl && { use gnutls && echo --with-crypto=gnutls || echo --with-crypto=openssl; }) \
+ $(use_with systemd libsystemd) \
+ $(use_with zeroconf avahi)
+}