summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Molik <dan@danmolik.com>2019-11-14 06:21:33 -0500
committerJoonas Niilola <juippis@gentoo.org>2019-11-16 11:45:49 +0200
commita634a38300b2d20769af66203d2a20013ed3bffd (patch)
tree951275884fb6c233bc9791bc21655511d7ab7c9e /dev-util/packer
parentnet-im/signal-desktop-bin: remove old version (diff)
downloadgentoo-a634a38300b2d20769af66203d2a20013ed3bffd.tar.gz
gentoo-a634a38300b2d20769af66203d2a20013ed3bffd.tar.bz2
gentoo-a634a38300b2d20769af66203d2a20013ed3bffd.zip
dev-util/packer: version bump to 1.4.5
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Dan Molik <dan@danmolik.com> Tested-by: Dan Molik <dan@danmolik.com> Closes: https://github.com/gentoo/gentoo/pull/13647 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util/packer')
-rw-r--r--dev-util/packer/Manifest1
-rw-r--r--dev-util/packer/packer-1.4.5.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/packer/Manifest b/dev-util/packer/Manifest
index 40db9723997f..5a397482b258 100644
--- a/dev-util/packer/Manifest
+++ b/dev-util/packer/Manifest
@@ -2,3 +2,4 @@ DIST packer-1.3.5.tar.gz 9198704 BLAKE2B 210c824aa61fed8ab58ea6eed2a1804d8b144e7
DIST packer-1.4.0.tar.gz 9794922 BLAKE2B 2e1d817e0a3f549255ecd8693d6d99b2e45df2e8fb0acc128f03bd1448f28afa865a0849ccf58e9a562ef50b901ea86efd29fe29747c126aa98c05456638719f SHA512 d2dbeb99d1fe44a427d2997eeb4ff6ae66bdf2d7f8f08e2105f8614487a6565b8bc263cf8aab8413520783a4dde18d150aae6c69db171fe1cfab3ee1bd0a0743
DIST packer-1.4.1.tar.gz 11279518 BLAKE2B 7b1b966af8cac73826fc8f5a1cb39183fd2ae1d3b7da6d7408cbb7c3342a0fd2ba84cf1df89ea9edc41353c0bbb6c874347745a91c3eaa1a742521c79500f21a SHA512 4038990655eecf412be9dae9edd09a300543a3b0b841c982631cb48f4905388f9dbf26a9b0ac3cb77628d1e650600b7d3b89a1694f746dfdef086a621078cde1
DIST packer-1.4.4.tar.gz 12811202 BLAKE2B 7a59f0252ac3d8158d64806e54fe459fe154bdc11b67539e4a39e7c79273bba6c5814cec0128c177a51e48bcf9172692d3eb3c7e789b768019c329c111fd5a0c SHA512 c4d2ca049b442fbbc65214ae75f5c85dc87b09eac8711891c4678ff3b2a676d00a051c08448a7a99b7a0977d4a04ad8bc559fd09885b520e6a8eb2dfc33ba50a
+DIST packer-1.4.5.tar.gz 13705057 BLAKE2B d23527e8bb0104e3f0206f5a82eb93fbe15a9542409bcce13cefd49fa83a47c0262f48e74ff951990211de9f85fc32efd41bbd4ed286b3462aed86df68afebc8 SHA512 b2a3ae27612c78fcfcb2ac655437faf2cff6e587fd10033b39ddaca8b92b634b93ecd0ae7e3ee43253ee716a2c0f7da532b3ae0ce33c59d1d3896f9187d9a657
diff --git a/dev-util/packer/packer-1.4.5.ebuild b/dev-util/packer/packer-1.4.5.ebuild
new file mode 100644
index 000000000000..a361a43a1fa3
--- /dev/null
+++ b/dev-util/packer/packer-1.4.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit golang-base go-module
+
+DESCRIPTION="A tool to create identical machine images for multiple platforms"
+HOMEPAGE="https://www.packer.io"
+
+EGO_PN="github.com/hashicorp/packer"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 BSD-4 ECL-2.0 icu imagemagick ISC JSON MIT MPL-2.0"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+DEPEND=""
+
+DOCS=( {README,CHANGELOG}.md )
+
+src_compile() {
+ GOCACHE="${T}/go-cache" go build \
+ -work -o "bin/${PN}" ./ || die
+}
+
+src_install() {
+ dobin bin/packer
+
+ einstalldocs
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/zsh-completion/_packer
+}