summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2015-08-16 22:22:46 +0900
committerNaohiro Aota <naota@gentoo.org>2015-08-16 22:24:49 +0900
commit2a84d30e55502c01c27fa176e3e09c09c59361d7 (patch)
tree829d7d1d8a7a63243db9f22bdc3a15f45986c67e /dev-util/perf/files
parentnet-misc/knemo: Fix build, bug 555784 (diff)
downloadgentoo-2a84d30e55502c01c27fa176e3e09c09c59361d7.tar.gz
gentoo-2a84d30e55502c01c27fa176e3e09c09c59361d7.tar.bz2
gentoo-2a84d30e55502c01c27fa176e3e09c09c59361d7.zip
dev-util/perf: fix install dir
perf binary and libs are accidentaly installed under / not /usr. Add a patch to fix "prefix=" behavior and reuse prefix argument.
Diffstat (limited to 'dev-util/perf/files')
-rw-r--r--dev-util/perf/files/perf-4.1.5-prefix.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/perf/files/perf-4.1.5-prefix.patch b/dev-util/perf/files/perf-4.1.5-prefix.patch
new file mode 100644
index 000000000000..0c4dff011306
--- /dev/null
+++ b/dev-util/perf/files/perf-4.1.5-prefix.patch
@@ -0,0 +1,43 @@
+commit 75e84ab906ef8935cff3df3d8929f1bafea81599
+Author: Lukas Wunner <lukas@wunner.de>
+Date: Thu Jun 18 13:00:32 2015 +0200
+
+ perf tools: Fix build breakage if prefix= is specified
+
+ Invoking Makefile.perf with prefix= breaks the build since Makefile.perf
+ hands that variable down to Makefile.build where it overrides
+
+ prefix := $(subst ./,,$(OUTPUT)$(dir)/)
+
+ leading to errors like this:
+
+ No rule to make target '/usrabspath.o', needed by '/usrlibperf-in.o'
+
+ Signed-off-by: Lukas Wunner <lukas@wunner.de>
+ Acked-by: Jiri Olsa <jolsa@kernel.org>
+ Cc: David Ahern <dsahern@gmail.com>
+ Fixes: c819e2cf2eb6f65d3208d195d7a0edef6108d5
+ Link: http://lkml.kernel.org/r/5582c48a.84a22b0a.a918.5285SMTPIN_ADDED_MISSING@mx.google.com
+ Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
+
+diff --git a/tools/build/Makefile.build b/tools/build/Makefile.build
+index 10df572..98cfc38 100644
+--- a/tools/build/Makefile.build
++++ b/tools/build/Makefile.build
+@@ -94,12 +94,12 @@ obj-y := $(patsubst %/, %/$(obj)-in.o, $(obj-y))
+ subdir-obj-y := $(filter %/$(obj)-in.o, $(obj-y))
+
+ # '$(OUTPUT)/dir' prefix to all objects
+-prefix := $(subst ./,,$(OUTPUT)$(dir)/)
+-obj-y := $(addprefix $(prefix),$(obj-y))
+-subdir-obj-y := $(addprefix $(prefix),$(subdir-obj-y))
++objprefix := $(subst ./,,$(OUTPUT)$(dir)/)
++obj-y := $(addprefix $(objprefix),$(obj-y))
++subdir-obj-y := $(addprefix $(objprefix),$(subdir-obj-y))
+
+ # Final '$(obj)-in.o' object
+-in-target := $(prefix)$(obj)-in.o
++in-target := $(objprefix)$(obj)-in.o
+
+ PHONY += $(subdir-y)
+