summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2021-01-14 20:03:12 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2021-01-14 20:10:56 +0300
commit077594f6d42c9a0115783ce07d533d8198c4df64 (patch)
tree00cbd3a14d710aeab05d2d548945ea6020e18267 /dev-util/pretrace
parentapp-editors/nano: Synced live ebuild (diff)
downloadgentoo-077594f6d42c9a0115783ce07d533d8198c4df64.tar.gz
gentoo-077594f6d42c9a0115783ce07d533d8198c4df64.tar.bz2
gentoo-077594f6d42c9a0115783ce07d533d8198c4df64.zip
dev-util/pretrace: fix QA issues
- Align build patch to -p1 (bug 651256) - Update homepage and src uri - Install docs to ${PN}-${PVR} instead of ${PN}-${PV} - Do not compress man pages - Provide soname for the library Closes: https://bugs.gentoo.org/651256 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'dev-util/pretrace')
-rw-r--r--dev-util/pretrace/Manifest1
-rw-r--r--dev-util/pretrace/files/pretrace-0.4-build.patch4
-rw-r--r--dev-util/pretrace/files/pretrace-0.4-qa.patch39
-rw-r--r--dev-util/pretrace/pretrace-0.4-r2.ebuild31
4 files changed, 73 insertions, 2 deletions
diff --git a/dev-util/pretrace/Manifest b/dev-util/pretrace/Manifest
index 07fb758cb0f1..97c797900f13 100644
--- a/dev-util/pretrace/Manifest
+++ b/dev-util/pretrace/Manifest
@@ -1 +1,2 @@
DIST libpretrace-0.4.tar.gz 7370 BLAKE2B 08fb2022433af807675ef089dcf1fbd642c165b353959f81547c2f65fd9e60c49b7494c661f81698c738bd27a3cdbd28d6a227589ef7a2906c5fa930d9709fc6 SHA512 64d1041ce398c73342ed371ebac4f656620c9ae4bc6da1b56b43bccd9898564a44dfe7bfaf3d4c865b89c5924b9d03aa21f393dcbafc185f84ac4b9ea2eb17d8
+DIST pretrace-0.4.tar.xz 6988 BLAKE2B a9b05aa106142fa090e09bd6c07d2972be72453e1bfe5a15a0b67c8bb5c3a20c2e19ad03dc738f24b6bcbee5629ad47438cdf04b1eab8c1d757fe4d62ee59a9e SHA512 cdd70b9b06451c0142c79b50f2264c034bdc8d815edaaeb78bbde55127a31a68e49df7ba2d6599bd108f9161f768afca84e85a917ef7353b1ace9e2256be84ef
diff --git a/dev-util/pretrace/files/pretrace-0.4-build.patch b/dev-util/pretrace/files/pretrace-0.4-build.patch
index 4d7056fa83f7..9db1cb241e7b 100644
--- a/dev-util/pretrace/files/pretrace-0.4-build.patch
+++ b/dev-util/pretrace/files/pretrace-0.4-build.patch
@@ -2,8 +2,8 @@ fix building with newer glibc
http://bugs.gentoo.org/227923
---- pretrace.h
-+++ pretrace.h
+--- a/pretrace.h
++++ b/pretrace.h
@@ -20,3 +20,8 @@
#include <sys/time.h>
# define RANDOMIZE(x) { struct timeval tv; gettimeofday(&tv, NULL); x = tv.tv_usec; }
diff --git a/dev-util/pretrace/files/pretrace-0.4-qa.patch b/dev-util/pretrace/files/pretrace-0.4-qa.patch
new file mode 100644
index 000000000000..8cf40e796a12
--- /dev/null
+++ b/dev-util/pretrace/files/pretrace-0.4-qa.patch
@@ -0,0 +1,39 @@
+--- pretrace-0.4/Makefile.orig 2021-01-14 13:31:45.950615134 +0300
++++ pretrace-0.4/Makefile 2021-01-14 13:32:04.940676578 +0300
+@@ -2,14 +2,14 @@
+ # $Id: Makefile,v 1.1 2005/07/27 07:45:37 taviso Exp $
+ #
+
+-VERSION=0.4
++VERSION?=0.4
+ PREFIX=/usr/local
+ DOCDIR=$(PREFIX)/share/doc/pretrace-$(VERSION)
+ LIBDIR=$(PREFIX)/lib
+ BINDIR=$(PREFIX)/bin
+ MANDIR=$(PREFIX)/share/man
+
+-all: libpretrace.so ptgenmap doc
++all: libpretrace.so ptgenmap
+ @echo 'libpretrace.so has been built, please see README for instructions.'
+ @echo 'type `make install` to install to $(PREFIX)'
+
+@@ -26,7 +26,7 @@
+ $(CC) $(CFLAGS) -Wall -g -fPIC -c trie.c
+
+ libpretrace.so: libpretrace.o trie.o
+- $(CC) $(CFLAGS) $(LDFLAGS) -g -shared -o libpretrace.so libpretrace.o trie.o
++ $(CC) $(CFLAGS) $(LDFLAGS) -g -shared -Wl,-soname,libpretrace.so -o libpretrace.so libpretrace.o trie.o
+
+ doc:
+ gzip -9c pretrace.3 > pretrace.3.gz
+@@ -38,8 +41,8 @@
+ install -m 0755 libpretrace.so $(LIBDIR)
+ install -m 0755 ptgenmap $(BINDIR)
+ install -m 0644 README pretrace.conf.example ChangeLog $(DOCDIR)
+- install -m 0644 pretrace.3.gz $(MANDIR)/man3
+- install -m 0644 ptgenmap.8.gz $(MANDIR)/man8
++ install -m 0644 pretrace.3 $(MANDIR)/man3
++ install -m 0644 ptgenmap.8 $(MANDIR)/man8
+
+ clean:
+ -rm -f libpretrace.so libpretrace.o trie.o ptgenmap.o ptgenmap *~
diff --git a/dev-util/pretrace/pretrace-0.4-r2.ebuild b/dev-util/pretrace/pretrace-0.4-r2.ebuild
new file mode 100644
index 000000000000..c6ff1edc5859
--- /dev/null
+++ b/dev-util/pretrace/pretrace-0.4-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit readme.gentoo-r1
+
+DESCRIPTION="start dynamically linked applications under debugging environment"
+HOMEPAGE="https://github.com/robholland/pretrace"
+SRC_URI="https://dev.gentoo.org/~bircoph/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DOC_CONTENTS="Remember to execute ptgenmap after modifying pretrace.conf"
+
+PATCHES=(
+ "${FILESDIR}"/${P}--as-needed.diff
+ "${FILESDIR}"/${P}-build.patch #227923
+ "${FILESDIR}"/${P}-qa.patch
+)
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man3 /usr/share/man/man8
+ emake DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" PREFIX="${D}/usr" VERSION="${PVR}" install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}